MapleSim Connector for FMI Installation and Licensing Guide


MapleSim 6 Connector for FMI Installation and Licensing Guide
Maple Requirements
Microsoft Visual Studio Requirements
MapleSim 6 Connector for FMI Installation Using a Single User License
Activating Single User Versions
MapleSim 6 Connector for FMI Installation Using a Network License
Windows Silent Installation
Installing and Setting Up a Microsoft Visual C++ Compiler
Configure the License Manager
Named Network Licensing
Getting Started with the MapleSim Connector for FMI
System Requirements
Trademarks

MapleSim 6 Connector for FMI Installation and Licensing Guide

The MapleSim Connector for FMI package is a collection of procedures for generating and compiling FMI source code from MapleSim models in a Maple standard worksheet, generating the FMI archive from a MapleSim system and compiling the generated FMI component into a shared library. The FMI (Functional Mockup Interface) itself, is a vendor and tool neutral standard interface used for model, software and hardware-in-the-loop simulation. For more information about the FMI, see http://functional-mockup-interface.org/index.html.

Maple Requirements

Before installing MapleSim 6 Connector for FMI, Maple 16.01 and MapleSim 6 must be installed and activated on your computer. For Maple and MapleSim installation and activation instructions, see the Maple 16 Installation and Licensing Guide and the MapleSim 6 Installation and Licensing Guide found in the Install.html files on your product installation discs.

Microsoft Visual Studio Requirements

On Windows 32-bit and 64-bit platforms, the MapleSim Connector for FMI requires that the Microsoft® Visual C++ compiler be installed. For instructions on obtaining and installing the Microsoft Visual C++ compiler see Installing and Setting Up a Microsoft Visual C++ Compiler.

MapleSim 6 Connector for FMI Installation Using a Single User License

32-bit Windows Single User Installation

For Windows® XP, Windows Server® 2008, Windows Vista®, and Windows® 7 single user installation, read this section. For 64-bit Windows, see 64-bit Windows Single User Installation.

During the installation, you will need your purchase code, generally sent to you in an email.

To install MapleSim 6 Connector for FMI on your Windows operating system, read and complete the following tasks

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim Connector for FMI6WindowsInstaller.exe from the install disc.
  • From download

Double-click MapleSim Connector for FMI6WindowsInstaller.exe from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use MapleSim 6 Connector for FMI. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

64-bit Windows Single User Installation

During the installation, you will need your purchase code, generally sent to you in an email.

To install MapleSim 6 Connector for FMI on your Windows operating system, read and complete the following tasks

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MS6FMIConnectorWindowsX86_64Installer.exe from the install disc.
  • From download

Double-click MS6FMIConnectorWindowsX86_64Installer.exe from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use MapleSim 6 Connector for FMI. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Macintosh Single User Installation

For Macintosh® Intel 32- and 64-bit installation instructions, read this section.

During the installation, you will need your purchase code, generally sent to you in an email.

To install MapleSim 6 Connector for FMI on your Macintosh operating system, read and complete the following tasks:

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim Connector for FMI6MacInstaller.dmg from the install disc, then double-click MS6FMIConnectorMacInstaller.
  • From download

Double-click MapleSim Connector for FMI6MacInstaller.dmg from where you downloaded the file, then double-click MS6FMIConnectorMacInstaller.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use MapleSim 6 Connector for FMI. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

32-bit Linux Single User Installation

During the installation, you will need your purchase code, generally sent to you in an email.

To install MapleSim 6 Connector for FMI on your 32-bit Linux® operating systems, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run MS6FMIConnectorLinux32Installer.bin from the install disc
  • From download

Run MS6FMIConnectorLinux32Installer.bin from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use MapleSim 6 Connector for FMI. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Shortcuts for Desktop and Applications menus

During installation, a FMIConnector6.desktop file is created in the bin directory of your MapleSim 6 Connector for FMI installation. If you request the installer to have a shortcut placed on your desktop, this file is also created in the ~/Desktop directory. If you wish to have a shortcut placed in your Applications menu, the FMIConnector6.desktop file can be copied to /usr/share/applications (which may require root access) or ~/.local/share/applications.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

64-bit Linux Single User Installation

During the installation, you will need your purchase code, generally sent to you in an email.

To install MapleSim 6 Connector for FMI on your 64-bit Linux® operating systems, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run MS6FMIConnectorLinuxX86_64Installer.bin from the install disc.
  • From download

Run MS6FMIConnectorLinuxX86_64Installer.bin from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Single User License .
  1. When prompted, enter the purchase code and the required information to complete activation.
  1. If you activated successfully, you are ready to use MapleSim 6 Connector for FMI. If you had problems activating or chose not to activate during the installation, see Activating Single User Versions.

Shortcuts for Desktop and Applications menus

During installation, a FMIConnector6.desktop file is created in the bin directory of your MapleSim 6 Connector for FMI installation. If you request the installer to have a shortcut placed on your desktop, this file is also created in the ~/Desktop directory. If you wish to have a shortcut placed in your Applications menu, the FMIConnector6.desktop file can be copied to /usr/share/applications (which may require root access) or ~/.local/share/applications.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Activating Single User Versions

MapleSim 6 Connector for FMI requires a license file to operate. License files for earlier versions of MapleSim Connector for FMI will not work with MapleSim 6 Connector for FMI. You must activate the single user version of MapleSim 6 Connector for FMI to obtain your license file. If you are running a single user installer, you can activate during the installation process. If you do not activate during the installation process, follow the steps below.

Note: Activation requires an Internet connection. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.

Windows

  1. To launch the Maplesoft Activation window, select Start>(All) Programs>MapleSim 6 Connector for FMI>Tools>Activate MapleSim 6 Connector for FMI. Note: If you are using Windows Vista or Windows 7, right-click Activate MapleSim 6 Connector for FMI and select Run as administrator.
  1. When the window opens, you will be prompted to enter your purchase code. After you have entered your purchase code, click Next. Note: If you are activating behind a proxy server, select the Yes option, and make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A MapleSim 6 Connector for FMI license file (FMIConnector.dat) will be saved in the license folder of your Maple 16 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Linux

  1. To launch the Maplesoft Activation window, run the activation script located in the $HOME/Maple16/toolbox/FMIConnector/license directory.
  1. When the window opens, you will be prompted to enter your purchase code. After you have entered your purchase code, click Next. Note: If you are activating behind a proxy server, select the Yes option, and make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A MapleSim 6 Connector for FMI license file (FMIConnector.dat) will be saved in the license folder of your Maple 16 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Macintosh

  1. To launch the Maplesoft Activation window, run the activation script located in the toolbox/FMIConnector/license folder of your 16 installation. By default, /Library/Frameworks/Maple.framework/Versions/16/toolbox/FMIConnector/license.
  1. When the window opens, you will be prompted to enter your purchase code. After you have entered your purchase code, click Next. Note: If you are activating behind a proxy server, select the Yes option, and make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information. Click Next when this is complete.

A MapleSim 6 Connector for FMI license file (FMIConnector.dat) will be saved in the license folder of your Maple 16 installation. If you experience difficulties with activation, check our FAQs page at http://www.maplesoft.com/support/Faqs/Activation.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

MapleSim 6 Connector for FMI Installation Using a Network License

32-bit Windows Installation Using a Network License

For Windows XP, Windows Server 2008, Windows Vista, and Windows 7 installation using a network license, read this section. For 64-bit Windows, see 64-bit Windows Installation Using a Network License.

To install MapleSim 6 Connector for FMI on your Windows operating system using a network license, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim Connector for FMI6WindowsInstaller.exe from the install disc.
  • From download

Double-click MapleSim Connector for FMI6WindowsInstaller.exe from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. MapleSim 6 Connector for FMI is now installed. Prior to using MapleSim 6 Connector for FMI, you need to Configure the License Manager.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

64-bit Windows Installation Using a Network License

To install MapleSim 6 Connector for FMI on your Windows operating system using a network license, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MS6FMIConnectorWindowsX86_64Installer.exe from the install disc.
  • From download

Double-click MS6FMIConnectorWindowsX86_64Installer.exe from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. MapleSim 6 Connector for FMI is now installed. Prior to using MapleSim 6 Connector for FMI, you need to Configure the License Manager.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Macintosh Installation Using a Network License

For Macintosh® Intel 32- and 64-bit installation instructions, read this section.

To install MapleSim 6 Connector for FMI on your Macintosh operating system, read and complete the following tasks:

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click MapleSim Connector for FMI6MacInstaller.dmg from the install disc, then double-click MS6FMIConnectorMacInstaller.
  • From download

Double-click MapleSim Connector for FMI6MacInstaller.dmg from where you downloaded the file, then double-click MS6FMIConnectorMacInstaller.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. MapleSim 6 Connector for FMI is now installed. Prior to using MapleSim 6 Connector for FMI, you need to Configure the License Manager.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

32-bit Linux Installation Using a Network License

To install MapleSim 6 Connector for FMI on your 32-bit Linux® operating systems, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run MS6FMIConnectorLinux32Installer.bin from the install disc
  • From download

Run MS6FMIConnectorLinux32Installer.bin from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. MapleSim 6 Connector for FMI is now installed. Prior to using MapleSim 6 Connector for FMI, you need to Configure the License Manager.

Shortcuts for Desktop and Applications menus

During installation, a FMIConnector6.desktop file is created in the bin directory of your MapleSim 6 Connector for FMI installation. If you request the installer to have a shortcut placed on your desktop, this file is also created in the ~/Desktop directory. If you wish to have a shortcut placed in your Applications menu, the FMIConnector6.desktop file can be copied to /usr/share/applications (which may require root access) or ~/.local/share/applications.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

64-bit Linux Installation Using a Network License

To install MapleSim 6 Connector for FMI on your 64-bit Linux® operating systems, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the MapleSim Connector for FMI files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. Close all programs.

Install MapleSim 6 Connector for FMI

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run MS6FMIConnectorLinuxX86_64Installer.bin from the install disc.
  • From download

Run MS6FMIConnectorLinuxX86_64Installer.bin from where you downloaded the file.

  1. Follow the on-screen instructions.
  1. In the Choose The Type of Licensing screen, select Network License .
  1. When prompted, enter the name or IP address of the license server.
  1. MapleSim 6 Connector for FMI is now installed. Prior to using MapleSim 6 Connector for FMI, you need to Configure the License Manager.

Shortcuts for Desktop and Applications menus

During installation, a FMIConnector6.desktop file is created in the bin directory of your MapleSim 6 Connector for FMI installation. If you request the installer to have a shortcut placed on your desktop, this file is also created in the ~/Desktop directory. If you wish to have a shortcut placed in your Applications menu, the FMIConnector6.desktop file can be copied to /usr/share/applications (which may require root access) or ~/.local/share/applications.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Windows Silent Installation

On Windows, it is possible to install the network version of MapleSim Connector for FMI using a silent mode option. For Windows XP, Windows Server 2008, Windows Vista, or Windows 7 (32-bit or 64-bit) follow these instructions. You must ensure that the information in the resource file is accurate.

Pre-installation Instructions

  1. Check the Windows System Requirements.
  1. Close all programs, particularly Microsoft Excel and any previous release of MapleSim Connector for FMI
  1. Log on as administrator or ensure that you have administrator privileges
  1. Create a resource file.

You can create a resource file automatically by running the installer with the command MapleSim Connector for FMI6WindowsInstaller.exe -r <PATH>\installer.properties (32-bit Windows) or MS6FMIConnectorWindowsX86_64Installer.exe -r <PATH>\installer.properties (64-bit Windows), where <PATH> is the path to your specified directory. Follow the on-screen instructions and complete the installation.

You can use the installer.properties file generated by the -r flag or you can create your own using the following example as a template:

INSTALLER_UI=SILENT

#Choose Install Folder

#---------------------

USER_INSTALL_DIR=C:\Program Files\Maple 16\toolbox\FMIConnector

#Install Desktop Shortcuts

#-------------------------

DESKTOP_SHORTCUTS="Yes",""

DESKTOP_SHORTCUTS_1=Yes

DESKTOP_SHORTCUTS_2=

DESKTOP_SHORTCUTS_BOOLEAN_1=1

DESKTOP_SHORTCUTS_BOOLEAN_2=0

#Choose Watcom Install Folder

#----------------------------

WATCOM_INSTALL_FOLDER=C:\watcom-1.3

#MapleSim Connector for FMI Worksheet Association

#----------------------------

WKS_ASSOC_RESULT="Yes",""

WKS_ASSOC_RESULT_1=Yes

WKS_ASSOC_RESULT_2=

WKS_ASSOC_RESULT_BOOLEAN_1=1

WKS_ASSOC_RESULT_BOOLEAN_2=0

#Choose the Type of Licensing

#----------------------------

LICENSE="","Network License"

LICENSE_1=

LICENSE_2=Network License

LICENSE_BOOLEAN_1=0

LICENSE_BOOLEAN_2=1

LICENSE server

#----------------------------

LICENSE_SERVER=myserver.mydomain.com

PORT_NUMBER=

  1. Open a command prompt window.
  1. Browse to the directory in which your MapleSim Connector for FMI6WindowsInstaller.exe or MS6FMIConnectorWindowsX86_64Installer.exe file is located.
  1. Run the silent installation process with the command MapleSim Connector for FMI6WindowsInstaller.exe -f installer.properties (32-bit Windows) or MS6FMIConnectorWindowsX86_64Installer.exe -f installer.properties.

Note: If you created your installer.properties file in a directory other than the directory in which the MapleSim Connector for FMI6WindowsInstaller.exe or MS6FMIConnectorWindowsX86_64Installer.exe file is located, you must specify the path to the installer.properties file when you run this command.

Notes

  1. The INSTALLER_UI=SILENT line is not added automatically to the installer.properties file if it was created with the -r flag during installation. If the -r flag was used to create the installer.properties file, INSTALLER_UI=SILENT must be added as the first item in the file.
  1. The template assumes MapleSim 6 Connector for FMI will be installed into the C:\Program Files\Maple 16\toolbox\MapleSim Connector for FMI folder. If another location is desired, change the USER_INSTALL_DIR accordingly.
  1. The template assumes MapleSim 6 Connector for FMI desktop icons will be placed on your desktop. To change this, replace the lines in the "Install Desktop Shortcuts" section with:

DESKTOP_SHORTCUTS="","No"

DESKTOP_SHORTCUTS_1=

DESKTOP_SHORTCUTS_2=No

DESKTOP_SHORTCUTS_BOOLEAN_1=0

DESKTOP_SHORTCUTS_BOOLEAN_2=1

  1. If required, the location of the WATCOM compiler can be changed. The pathname must not contain any spaces. If you omit the WATCOM_INSTALL_FOLDER field entirely, the WATCOM compiler will not be installed.
  1. The template assumes MapleSim 6 Connector for FMI will be the default MapleSim Connector for FMI version (assuming other versions of MapleSim Connector for FMI are installed on the system). To change this, replace the lines in the "MapleSim Connector for FMI Worksheet Association" section with:

WKS_ASSOC_RESULT="","No"

WKS_ASSOC_RESULT_1=

WKS_ASSOC_RESULT_2=No

WKS_ASSOC_RESULT_BOOLEAN_1=0

WKS_ASSOC_RESULT_BOOLEAN_2=1

  1. Change the license server name (required) and add a port number (optional) accordingly

Additional Information

  • You are not provided with any feedback when you run the installer in this mode
  • While you can install the single-user version of MapleSim Connector for FMI silently, it is not possible to activate the product at this time. After the silent installation of the single user version of MapleSim 6 Connector for FMI is complete, from the Start menu, select All Programs, then MapleSim 6 Connector for FMI, then Tools and then Activate MapleSim 6 Connector for FMI.

Silently Uninstalling on Windows

  1. To perform a silent uninstallation of MapleSim Connector for FMI, at a command prompt, run the following command.

"C:\Program Files\Maple 16\toolbox\MapleSim Connector for FMI\Uninstall_MapleSim Connector for FMI\Uninstall.exe" -i silent

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Installing and Setting Up a Microsoft Visual C++ Compiler

Note: If you are using Windows Vista or Windows 7, you will need to log into an account with administrative privileges to set up and install the Microsoft Visual C++ compiler.

To install and set up the required software on your computer, perform the following steps:

Download and Install Microsoft Visual C++ Express Edition

Setting Up the Visual Studio C++ Compiler

Download and Install Microsoft Visual C++ Express Edition

Download and install the following software on your computer

  • Microsoft Visual C++ 2010 Express Edition, which is a free download.

Note: To download Microsoft Visual C++ 2010 Edition do the following:

  1. Select the Visual Studio 2010 Express tab.
  1. Click the Visual C++ 2010 Express Edition link.
  1. Select your language.
  1. Click the Free Download button.

Setting Up the Visual Studio C++ Compiler

Every time you launch the Standard Worksheet version of Maple your computer is automatically scanned for a suitable Microsoft Visual Studio C++ compiler. Supported compiler versions are: 2010, 2008, 2005 and 2003.

If your supported version of Visual Studio C++ compiler is not detected, you can manually define the %LIB%, %INCLUDE% and %PATH% environment variables used by the compiler or you can set up the Microsoft Visual C++ compiler for Maple by specifying the path of the vcvars64.bat file created during the Maple installation process. To specify the path of the vcvars64.bat file do the following:

  • If Maple is already installed on your computer, you can run a command within Maple to specify the path of the file. Perform the following steps:
  1. Open Maple.
  1. At the Maple prompt, type Compiler:-Setup() and press Enter.
  1. In the dialog box, specify the full path of the vcvars64.bat file.
  1. Close Maple.
  • Note: The Compiler:-Setup() command is available in the Standard Worksheet version of Maple. If you are using the Command line version of Maple you must manually define the %LIB%, %INCLUDE% and %PATH% environment variables.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Configure the License Manager

Configure the License Manager for Windows

Before starting the Windows Network version of MapleSim 6 Connector for FMI, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and Activation Utilities

  1. Double-click NetworkToolsInstaller_Windows.exe from the DVD or from where you downloaded the file.
  1. Close all programs, particularly Microsoft® Excel and any previous release of MapleSim Connector for FMI.
  1. Follow the on-screen instructions.

Activate a Network License

MapleSim 6 Connector for FMI requires a MapleSim 6 Connector for FMI license file to operate. License files for earlier versions of MapleSim Connector for FMI do not work with MapleSim 6 Connector for FMI. To obtain your license file, you must use the MapleSim Connector for FMI activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. From the Start menu, select (All) Programs>Maple Network Tools>Activate MapleSim Connector for FMI. Note: If you are using Windows Vista or Windows 7, right-click Activate MapleSim Connector for FMI and select Run as administrator.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  1. A license file, FMIConnector6.lic, will be saved to the C:\Program Files\Maple Network Tools\activate folder. You will need this license file in the next step.

Start the License Manager for MapleSim 6 Connector for FMI Only

The C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows directory contains license manager daemons (lmgrd and MapleSim Connector for FMIlmg) required to run MapleSim Connector for FMI, as well as utilities to assist you in installing and configuring FlexNet Publisher for your system.

Start the License Manager Daemons

If you intend to use a Novell® server, see Novell Networks.

To set up and start the license manager daemons on a Windows Network Server:

  1. From the Start menu, select (All) Programs>Maple Network Tools>LMTools11.7.
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab.
  1. In the Config Services property sheet, enter or browse to the following files:

Service Name

Enter a name for the service (optional)

Path to the lmgrd.exe file

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

Path to the license file

C:\Program Files\Maple Network Tools\activate\FMIConnector6.lic

Path to the debug log file Enter the path to the directory containing the debug log file. You must create this file manually (log.txt is the manually created file in the example below), as it is not automatically generated.

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows XP, Windows Vista and Windows 7
  1. To start the daemons at boot time (recommended), select the Start Server at Power Up check box
  1. Click Save Service. When prompted to save the service, click Yes
  1. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons

You can now use MapleSim 6 Connector for FMI

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Note: Maple 16 and associated toolbox licensing is compatible with licensing for Maple 14, but not with licensing for versions previous to Maple 14. Maple and toolboxes earlier than version 14 need to be running the Maple 13 version of the Maple Network Tools.

Complete the following tasks:

Stop the License Manager
  1. Go to the directory of the FlexNet Publisher utilities that are currently being used and double-click lmtools.exe. Alternatively, in the Start menu, select (All) Programs>Maple Network Tools>LMTools11.7
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab. From the Server Name list, select the service currently being used.
  1. Click the Start/Stop/Reread tab, then click Stop Server.
Move all MapleSim Connector for FMI License Files to a Common Directory

Using Windows Explorer, move all of the license files to a common directory, for example, C:\Program Files\Maple Network Tools\activate.

Start the License Manager Daemons
  1. From the Start menu, select (All) Programs>Maple Network Tools >LMTools11.7.
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab.
  1. In the Config Services property sheet, enter or browse for the following:

Service Name

Enter a name for the service (optional)

Path to the lmgrd.exe file

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

Path to the license file Note: The path to the license file should not contain a terminating backslash

C:\Program Files\Maple Network Tools\activate

Path to the debug log file Enter the path to the directory containing the debug log file. You must create this file manually (log.txt is the manually created file in the example below), as it is not automatically generated.

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows 2003, XP, Vista and 7.
  1. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  1. Click Save Service. When prompted to save the service, click Yes.
  1. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons.

You can now use your network licensed Maplesoft products.

Novell Networks

FlexNet Publisher does not run on Novell or IPX/SPX. Follow these instructions to install the license manager on any network that is exclusively a Novell environment.

  1. Install TCP/IP on all client machines.
  1. Select a Windows computer that has TCP/IP installed to act as a license server and run the license daemons using the Start License Manager for MapleSim 6 Connector for FMI Only instructions.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Configure the License Manager for Mac OS X

Before starting the Mac OS® X Network version of MapleSim 6 Connector for FMI, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and the Activation Utilities

  1. To begin installing the FlexNet Publisher and Activation Utilities, choose one of the following:
  1. Place the MapleSim 6 Connector for FMI DVD in the DVD-ROM drive.
  1. Double-click NetworkToolsInstaller_Mac.dmg from where you downloaded the file.
  1. Run the installer by double-clicking the NetworkToolsInstaller_Mac icon.
  1. Follow the on-screen instructions.

Activate a Network License

MapleSim 6 Connector for FMI requires a MapleSim 6 Connector for FMI license file to operate. License files for earlier versions of MapleSim Connector for FMI do not work with MapleSim 6 Connector for FMI. To obtain your license file, you must use the MapleSim Connector for FMI activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. From the Finder, open a terminal window from Applications -> Utilities.
  1. Change to the location of the activation utility directory. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.
  1. Run the activation script by issuing the command ./activation. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete
  1. When prompted, enter the name or IP address of the license server.
  1. A license file, FMIConnector6.lic, will be saved to the /Users/<username>/Applications/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for MapleSim 6 Connector for FMI Only

Start the License Manager Daemons

Before you can use MapleSim 6 Connector for FMI, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/.
  1. Start the license manager daemons
  1. To start the license manager daemon (lmgrd), enter the following command at the prompt:

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, /Users/<username>/Applications/Maple_Network_Tools/activate/FMIConnector6.lic), and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Help for Starting the License Server

If you have any problems starting the license server in the system boot up files, refer to http://www.flexerasoftware.com

You can now use MapleSim 6 Connector for FMI

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Note: Maple 16 and associated toolbox licensing is compatible with licensing for Maple 14, but not with licensing for versions previous to Maple 14. Maple and toolboxes earlier than version 14 need to be running the Maple 13 version of the Maple Network Tools.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For MapleSim 6 Connector for FMI, the default location is /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/. Enter the command:

./lmdown

Move all MapleSim Connector for FMI License Files to a Common Directory

Copy all the MapleSim Connector for FMI network license files to /Users/<username>/Applications/Maple_Network_Tools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/.
  1. When starting license manager daemons, you must enter the path to the directory containing all license files. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Configure the License Manager for UNIX and Linux

Before starting the UNIX Network version of MapleSim 6 Connector for FMI, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and the Activation Utilities

  1. Choose one of the following:
  1. On Linux 32-bit, run the NetworkToolsInstaller_Linux.bin file from the DVD or from where you downloaded the file.
  1. On Linux 64-bit, run the NetworkToolsInstaller_LinuxX86_64.bin file from the DVD or from where you downloaded the file.
  1. On Solaris, run the NetworkToolsInstaller_Sun.bin file from the DVD or from where you downloaded the file.
  1. Follow the on-screen instructions.

Activate a Network License

MapleSim 6 Connector for FMI requires a MapleSim 6 Connector for FMI license file to operate. License files for earlier versions of MapleSim Connector for FMI do not work with MapleSim 6 Connector for FMI. To obtain your license file, you must use the MapleSim Connector for FMI activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. Change to the location of the activation utility directory. By default, $HOME/Maple_Network_Tools/activate.
  1. Run the activation command. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is completed.
  1. A license file, FMIConnector6.lic, will be saved to the $HOME/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for MapleSim 6 Connector for FMI Only

Start the License Manager Daemons

Before you can use MapleSim 6 Connector for FMI, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/.
  1. Start the license manager daemons.

Using the C Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt,

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, $HOME/Maple_Network_Tools/activate/FMIConnector6.lic) and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Using the Korn or Bourne Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt:

nohup lmgrd -c license_file_path -l debug_log 2>&1 &

Run Daemons on Startup

To have the daemons run on startup, edit the appropriate boot script (such as /etc/rc.boot, /etc/rc.local, or /etc/rc2.d/Sxxxx). For example, if you run lmgrd as a boot startup script, you can run it as a regular user by using the following su command at the prompt:

su username -c \'umask 022; lmgrd_path -c license_file_path -l log_path\'

where username is a non-privileged user; lmgrd_path is the correct path to the lmgrd file, license_file_path is the full path of the network license file (by default, $HOME/Maple_Network_Tools/activate/FMIConnector6.lic), and log_path is the debug log file path. It is recommended that the network license file be called FMIConnector6.lic.

Help for Starting the License Server

If you have any problems starting the license server in the UNIX system boot up files, refer to http://www.flexerasoftware.com/.

You can now use MapleSim 6 Connector for FMI.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Note: Maple 16 and associated toolbox licensing is compatible with licensing for Maple 14, but not with licensing for versions previous to Maple 14. Maple and toolboxes earlier than version 14 need to be running the Maple 13 version of the Maple Network Tools.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For MapleSim 6 Connector for FMI, the default location is /usr/local/Maple_Network_Tools/FLEXlm/11.7/. Enter the command:

./lmdown
Move all MapleSim Connector for FMI License Files to a Common Directory

Copy all of the MapleSim Connector for FMI network license files to one folder, for example, $HOME/Maple_Network_Tools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/.
  1. When starting license manager daemons, you must enter the path to the directory containing all of your license files. By default, $HOME/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Named Network Licensing

Named Network Users run MapleSim Connector for FMI on their own client machines. These client machines are connected to the license server over the network. The Network Named User licensing option allows system administrators to strictly enforce which users, or client machines, may run MapleSim Connector for FMI.

When you install Maple Network Tools, an options file (.opt) is automatically created in the $Maple Network Tools/activate directory.

Note: The vendor daemon, maplelmg.opt, by default, looks for the options file with in the same directory that contains the license file used by the license server manager.

Setting Up Named Network Licensing

To set up Named Network User licensing, perform the following steps:

Edit the Options File

To manually edit the options file, perform the following steps:

  • Go to the directory that contains the options file. By default, this is $Maple Network Tools/activate.
  • INCLUDE lines in an options file state which users can run the product. Add an INCLUDE line for each product. If there is more than one user per product, add an INCLUDE line for each user, as well. Alternatively, you can use the GROUP syntax to combine authorized Named Users for a specific product.
Example 1: Specifying which users can run Maple 16, MapleSim 6, and MapleSim 6 Connector for FMI

INCLUDE Maple USER User1

INCLUDE Maple USER User2

INCLUDE Maple USER User3

INCLUDE Maple USER User4

INCLUDE FMIConnector USER User4

Example 2: Using `GROUP` syntax to specify users that can run Maple 16, MapleSim 6, and MapleSim 6 Connector for FMI

GROUP Maple_users User1 User2 User3 User4

INCLUDE Maple GROUP Maple_users

INCLUDE FMIConnector USER User4

Restart the License Manager.

You must restart the license manager for the changes to the options file to take effect.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Getting Started with the MapleSim Connector for FMI

When the installation and activation process is complete, start MapleSim. An FMI Connector Examples palette is displayed on the left side of the MapleSim window when the toolbox is installed.

For more information, see the MapleSim Connector for FMI Getting Started Guide, which can be found on your desktop.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

System Requirements

32-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows XP

Intel Pentium III 650 MHz or higher or fully compatible

2 GB

2 GB

Windows Vista

Intel Pentium III 1 GHz

2 GB

2 GB

Windows Server 2008

x86_64 1.4 GHz (single core) or x86_64 1.3 GHz (dual core) or equivalent

2 GB

2 GB

Windows 7

Intel Pentium III 1 GHz

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.

64-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows XP

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Vista

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Server 2008

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows 7

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

Macintosh System Requirements

Vendor

CPU

Operating System

Version

Recommended RAM

Hard Disk

Apple

Intel

OS X

10.6

2 GB

2 GB

Apple

64-bit Intel

OS X

10.6, 10.7

2 GB

2 GB

  • Java™ Runtime Environment 1.6.0_18 or higher installed
  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

32-bit Linux System Requirements

Vendor

Operating System Version

CPU

Recommended RAM

Hard Disk

Red Hat Enterprise Linux

5 update 5, 6

Intel Pentium III 650 MHz or equivalent

2 GB

2GB

SUSE Linux Enterprise Desktop

10 SP3, 11 SP1

Intel Pentium III 650 MHz or equivalent

2 GB

2 GB

Ubuntu

10.04 LTS, 11.10

Intel Pentium III 650 MHz or equivalent

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.

64-bit Linux System Requirements

Vendor

Operating System Version

CPU

Recommended RAM

Hard Disk

Red Hat Enterprise Linux

5 update 5,6

Intel 64 or AMD X86_64

2 GB

2 GB

SUSE Linux Enterprise Desktop

10 SP 3, 11 SP 1

Intel 64 or AMD X86_64

2 GB

2 GB

Ubuntu

10.04 LTS, 11.10

Intel 64 or AMD X86_64

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.

Trademarks

Note: Maple uses the Flexera Software Corporation FlexNet Publisher as its license manager. This document contains all the information you require for a standard Maple installation. For more information, refer to the FlexNet Publisher documentation at http://www.flexerasoftware.com/.

Maple, Maplesoft, and Waterloo Maple are trademarks of Waterloo Maple Inc.

Intel is a registered trademark of Intel Corporation.

Microsoft, Windows, Windows Server, Windows Vista, Excel, and Internet Explorer are registered trademarks of Microsoft Corporation.

Macintosh and Mac OS are registered trademarks of Apple Computer, Inc.

NVIDIA is a registered trademark of NVIDIA Corporation.

Java, JRE, and Solaris are registered trademarks of Oracle and/or its affiliates.

FLEXlm is a trademark of Flexera Software Corporation Corporation.

Linux is a registered trademark of Linus Torvalds.

All other brand names or product names are trademarks or registered trademarks of their respective companies.

Return to the top of the MapleSim 6 Connector for FMI Installation and Licensing Guide.