MapleSim Connector for LabVIEW and NI VeriStand Software インストールガイド

Maplesoft, a division of Waterloo Maple Inc.

インストール前のタスク

シングルユーザのインストール

ネットワークライセンスのインストール

はじめる前に

 


動作環境の確認

Maple および MapleSim の動作環境
LabVIEW および NI VeriStand Requirements の動作環境
Microsoft Visual Studio の動作環境
32-bit および 64-bit Windows 版の動作環境

Maple および MapleSim の動作環境

MapleSim™ Connector for LabVIEW® and NI VeriStand™ Software をインストールする前に、Maple™ 15 および MapleSim 5 がインストールされ、かつアクティベーションが完了されていなければなりません。Maple および MapleSim のインストール方法やライセンス設定方法については、製品のインストールメディア に付属する Maple 15 インストール・ライセンス設定ガイド および MapleSim インストールガイドInstall.html ファイルを参照してください。

LabVIEW および NI VeriStand 動作環境

MapleSim Connector for LabVIEW and NI VeriStand Software には、 LabVIEW 2009 or LabVIEW 2010 以降 および 生成したいブロックに応じた以下のアプリケーションをインストールする必要があります。

Microsoft Visual Studio の動作環境

MapleSim Connector for LabVIEW and NI VeriStand Software は、 Microsoft® Visual Studio 2003 又は、Microsoft Visual Studio 2005、Microsoft Visual Studio 2008, Microsoft Visual Studio 2010 が必要です。

32-bit および 64-bit Windows 版動作環境

OS バージョン
CPU

推奨メモリ

ハードディスク容量
Windows XP Pro
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
2 GB
2 GB
Windows XP Home
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
2 GB
2 GB
Windows Vista® Home Basic
Intel Pentium III
1 GHz
2 GB
2 GB
Windows Vista
Home Premium
Business
Ultimate Edition
Intel Pentium III
1 GHz
2 GB
2 GB
64-bit Windows 2008 Server
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
2 GB 2 GB
64-bit Windows (XP or Vista or 7)
AMD X86_64
1 GHz
Intel Xeon
Intel 64
2 GB 2 GB
Windows XP 日本語版
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
2 GB 2 GB
Windows XP 日本語版 (XP or Vista)
AMD X86_64
1 GHz
Intel Xeon
Intel 64
2 GB 2 GB
Windows Vista 日本語版
Intel Pentium III
1 GHz
2 GB 2 GB
Windows 7
Intel Pentium III
1 GHz
2 GB 2 GB
Windows 7 日本語版
Intel Pentium III
1 GHz
2 GB 2 GB

MapleSim Connector for LabVIEW and NI VeriStand Software のシングルユーザのインストール

インストール処理中には、電子メールにて送付されたパーチェイスコードが必要になりますので、あらかじめご用意下さい。

32-bit および 64-bit Windows版

  1. インストールメディア またはファイルをダウンロードしたフォルダから、 MS5LabVIEWVeriStandConnectorWindowsInstaller_ja.exe ファイルをダブルクリックします。
  2. スクリーンの指示に従います。MapleSim Connector for LabVIEW and NI VeriStand Software は、 c:\Program Files\Maple 15\toolbox\LabVIEWVeriStandConnector にインストールされます。



シングルユーザのアクティベーション

MapleSim Connector for LabVIEW and NI VeriStand Software を利用するには、MapleSim Connector for LabVIEW and NI VeriStand Software のライセンスファイルが必要となります。ライセンスファイルを取得するには、シングルユーザ版 MapleSim LabVIEW Connector をアクティベーション (認証) する必要があります。シングルユーザインストーラでは、インストール処理中にアクティベーションを実行することが可能です。インストール処理中にアクティ ベーションができなかった場合は、次の手順に従ってください。

[スタート] メニューから、 [プログラム] > [MapleSim 5 Connector for LabVIEW and NI VeriStand Software] > [Tools] > [Activate MapleSim 5 Connector for LabVIEW and NI VeriStand Software] の順に選択して、アクティベーションを実行することもできます。

MapleSim Connector for LabVIEW and NI VeriStand Software のライセンスファイル (LabVIEWVeriStandConnector.dat) は、ツールボックスをインストールしたフォルダの license フォルダに保存されます。


MapleSim Connector for LabVIEW and NI VeriStand Software のネットワークライセンスのインストール

32-bit 及び 64 bit Windows 版

  1. インストールメディア またはファイルをダウンロードしたフォルダから、 MS5LabVIEWVeriStandConnectorWindowsInstaller_ja.exe ファイルをダブルクリックします。
  2. スクリーンの指示に従います。
  3. [ライセンスタイプの選択] 画面で [ネットワークライセンス] を選択します。
  4. ダイアログが表示されたら、ライセンスサーバのホスト名または IP アドレスを入力します。

以上で、MapleSim Connector for LabVIEW and NI VeriStand Software はインストールされました。MapleSim Connector for LabVIEW and NI VeriStand Software を使用する前に、必ず ライセンスマネージャの設定 を行ってください。


ライセンスマネージャの設定

32-bit および 64-bit Windows 版ネットワークライセンス

32-bit および 64-bit Windows 版ネットワークライセンス

FLEXlm とアクティベーションユーティリティのインストール

  1. インストールメディア またはファイルをダウンロードした場所で NetworkToolsInstaller_Windows.exe をダブルクリックします。
  2. スクリーンの指示に従います。

ネットワークライセンスのアクティベーション

  1. C:\Program Files\Maple Network Tools\activate に移動します。
  2. activation.bat をダブルクリックします。
  3. パーチェイスコードおよびライセンスサーバのホスト名とホスト ID を入力します。プロキシサーバを経由してアクティベーションを行う場合は、 [次へ] をクリックする前に必要な情報を入力してください。
  4. アクティベーションを行うライセンス数等の必要な情報を入力し、 [次へ] をクリックします。これで、アクティベーションが完了します。
  5. ライセンスファイル LabVIEWVeriStandConnector5.lic は、 c:\Program Files\Maple Network Tools\activate フォルダに保存されます。次の手順では、このライセンスファイルが必要になります。

MapleSim Connector for LabVIEW and NI VeriStand Software のみのライセンスマネージャの起動

c:\Program Files\Maple Network Tools フォルダ下にある \FLEXlm\11.7\windows フォルダには、Maplesoft 製品の実行に必要なライセンスマネージャデーモン (lmgrd および maplelmg) と、お使いのシステムに FLEXlm をインストールして設定するときに役立つユーティリティが含まれています。

ライセンスマネージャデーモンの起動

Novell® サーバを利用する場合は、Novell Networksの項を参照してください。

Windows ネットワーク版ライセンスマネージャデーモンの設定および起動方法:

    1. [スタート] メニューから、[プログラム] > [Maple Network Tools] -> [LMTools11.7]
    2. [Service/License File] タブで、[Configuration using Services] をクリックします。
    3. [Config Services] タブをクリックします。
    4. [Config Services] プロパティシートで、次のファイルを入力または参照します:
Service Name サービス名を入力します (オプション)。
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
Path to the license file

C:\Program Files\Maple Network Tools\activate\LabVIEWVeriStandConnector5.lic
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. Windows 2003、Windows XP、Windows Vista、Windows 7 については、[Use Services] チェックボックスにチェックを付けることで、デーモンをサービスとして設定することができます (推奨)。
  2. システムの起動時にデーモンを起動させる場合は (推奨)、[Start Server at Power Up] チェックボックスにチェックを付けます。
  3. [Save Service] をクリックします。サービスを保存するためのダイアログが表示されたら、[Yes] をクリックします。
  4. [Start/Stop/Reread] タブを選択し、このタブのプロパティシートで [Start Server] をクリックしてライセンスマネージャデーモンを起動します。

以上で、MapleSim Connector for LabVIEW and NI VeriStand Software をお使い頂けます。

このガイドの先頭に戻ります。

複数の Maplesoft 製品のライセンスマネージャの起動

MapleSim 5、 Maple 15 および関連するツールボックスを実行するには、すべてのライセンスファイルを同一のフォルダに用意する必要があります。その他の FLEXlm ライセンスファイルを 1 箇所にまとめて保存している場合は、MapleSim のライセンスファイルも同じ場所に保存することができます。

注意: MapleSim 5、Maple 15 および関連するツールボックスのライセンスは、以前の Maple のバージョンのライセンスとの互換性がありません。MapleSim 5、Maple 15 および関連するツールボックスの Maple ネットワークツールは異なるマシーンにインストールし実行しなければなりません

以下の手順を実行します。

タスク 1:ライセンスマネージャの停止

    1. 現在使用している FLEXlm ユーティリティのあるフォルダに移動します。
    2. lmtools.exe をダブルクリックします。
    3. [Service/License File] タブで、[Configuration using Services] をクリックします。
    4. [Config Services] タブをクリックします。[Server Name リストから、現在使用しているサービスを選択します。
    5. [Start/Stop/Reread] タブをクリックしてから [Stop Server] をクリックします。

タスク 2:すべての Maple ライセンスファイルの共通のフォルダへの移動

Windows のエクスプローラを用いて、すべてのライセンスファイルを共通のフォルダ (例えば C:\Program Files\Maple Network Tools\activate) に移動します。

タスク 3:ライセンスマネージャデーモンの起動

    1. [スタート] メニューから、[プログラム] >[Maple Network Tools] > [LMTools11.7] を選択します。
    2. [Service/License File] タブで、[Configuration using Services] をクリックします。
    3. [Config Services] タブをクリックします。
    4. [Config Services] プロパティシートで、次を入力または参照します:
Service Name サービス名を入力します (オプション)。
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
Path to the license file

すべてのライセンスファイルが保存されているフォルダのパスを入力します。指定するのはフォルダのみとし、ライセンスファイルを直接指定しないでください。

C:\Program Files\Maple Network Tools\activate
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. Windows 2003、Windows XP、Windows Vista、Windows 7 については、[Use Services] チェックボックスにチェックを付けることで、デーモンをサービスとして設定することができます (推奨)。
  2. システムの起動時にデーモンを起動させる場合は (推奨)、[Start Server at Power Up] チェックボックスにチェックを付けます。
  3. サービス名を入力し、[Save Service]. をクリックします。サービスを保存するためのダイアログが表示されたら、[Yes] をクリックします。
  4. [Start/Stop/Reread] タブを選択し、[Start Server] をクリックしてライセンスマネージャデーモンを起動します。

以上で、ネットワークライセンス版の Maplesoft 製品をお使い頂けます。

Novell Networks

FLEXlm は Novell または IPX/SPX 上では動作しません。以下の指示に従って、Novell 環境下のみにあるすべてのネットワークに、ライセンスマネージャをインストールしてください。
  1. すべてのクライアントコンピュータに TCP/IP をインストールします。
  2. TCP/IP をインストールしてある Windows コンピュータをライセンスサーバとして 1 台選択し、MapleSim Connector for LabVIEW and NI VeriStand Software のみのライセンスマネージャの起動の指示に従って、ライセンスマネージャデーモンを実行します。

 


Named ネットワークライセンスの設定

Named ネットワークライセンスユーザはクライアントマシーンで LabVIEW Connector 5 を実行します。これらのクライアントはネットワークを経由してサーバに接続競れます。ネットワーク Named ユーザライセンスオプションはシステム管理者がどのユーザに、又はどのマシーンで LabVIEW Connector 5 を実行させるか厳密に管理することができます。

ネットワーク Named インストールのパーチェイスコードで Maple Network Tools をインストールする際には、オプションファイル (.opt) が $MAPLE NETWORK TOOLS/activateディレクトリに自動的に生成されます。

オプションファイルをマニュアルで変数するには以下の手順で行ないます。

例1: Maple 15, MapleSim 5 or LabVIEW Connector 5 を実行できるユーザを指定

INCLUDE Maple USER User1
INCLUDE Maple USER User2
INCLUDE Maple USER User3
INCLUDE Maple USER User4
INCLUDE MapleSim USER User4
INCLUDE LabVIEWConnector USER User4

例2: GROUP 構文を利用し Maple 15, MapleSim 5 or LabVIEW Connector 5 を実行できるユーザを指定

GROUP Maple_users User1 User2 User3 User4
INCLUDE Maple GROUP Maple_users
INCLUDE MapleSim USER User4
INCLUDE LabVIEWConnector USER User4


 

 


MapleSim Connector for LabVIEW and NI VeriStand Software Getting Started Guide

インストールとアクティベーションの処理が完了したら、MapleSim を起動します。ツールボックスをインストールすると、MapleSim ウィンドウの左側に [例題(LabVIEW Connector)] パレットが表示されます。

詳細については、MapleSim 5 Connector for LabVIEW and NI VeriStand Software Getting Started Guide を参照してください。このガイドは、デスクトップから参照できます。


登録商標

Maple, MapleSim, Maplesoft, Waterloo Maple は、Waterloo Maple Inc の登録商標です。
Microsoft, Windows, Windows Server, Windows Vistaは、 Microsoft Corporation の登録商標です。
Intel and Pentium は、 Intel Corporation の登録商標です。
Java Runtime Environment は、アメリカ合衆国及びその他の国における Sun Microsystems, Inc. の登録商標です。
LabVIEW, National Instruments, NI VeriStand は、 National Instruments の商標または登録商標です。

その他のブランド名または製品名は、各社の商標または登録商標です。