Grid Computing Toolbox 17 Installation and Licensing Guide


Grid Computing Toolbox 17 Installation and Licensing Guide
Grid Computing Toolbox 17 Installation Using a Network License
Configure the License Manager
Named Network Licensing
How to Configure the Grid Computing Toolbox
Getting Started With Grid Computing Toolbox 17
System Requirements
Trademarks

Grid Computing Toolbox 17 Installation and Licensing Guide

Note: The Grid Computing Toolbox installation provides an option for MPI Cluster installation. For details on Using the Grid Computing Toolbox with MPI see Using Grid MPI.txt.

Grid Computing Toolbox 17 Installation Using a Network License

32-bit Windows Installation Using a Network License

For Windows XP, Windows Server 2008, Windows Vista, Windows 7, Windows Server 2012, and Windows 8 installation using a network license, read this section. For 64-bit Windows, see 64-bit Windows Installation Using a Network License.

To install Grid Computing Toolbox 17 on your Windows operating system using a network license, read and complete the following tasks.

For Macintosh® Intel 32- and 64-bit installation instructions, read this section.

To install Grid Computing Toolbox 17 on your Macintosh operating system, read and complete the following tasks:

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the Grid Computing Toolbox files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. This product requires Maple 17 or later.

To identify your Maple release:

  1. Start Maple.
  1. From the Help menu, select About Maple. The About Maple 17 dialog indicates the release number.

To update to the latest Maple release:

From the Tools menu, select Check for Updates and follow the instructions. If that option is dimmed, obtain the update from the downloads section of the Maplesoft website.

  1. Close all programs.

Install Grid Computing Toolbox 17

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click GridComputingToolbox_Windows.exe from the install disc.
  • From download

Double-click GridComputingToolbox_Windows.exe from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Grid Computing Toolbox is installed to the following location:

C:\Program Files\Maple 17\toolbox\Grid

  1. When prompted, enter the name or IP address of the license server.
  1. Grid Computing Toolbox 17 is now installed. Prior to using Grid Computing Toolbox 17, you need to Configure the License Manager.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

64-bit Windows Installation Using a Network License

To install Grid Computing Toolbox 17 on your Windows operating system using a network license, read and complete the following tasks.

For Macintosh® Intel 32- and 64-bit installation instructions, read this section.

To install Grid Computing Toolbox 17 on your Macintosh operating system, read and complete the following tasks:

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the Grid Computing Toolbox files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. This product requires Maple 17 or later.

To identify your Maple release:

  1. Start Maple.
  1. From the Help menu, select About Maple. The About Maple 17 dialog indicates the release number.

To update to the latest Maple release:

From the Tools menu, select Check for Updates and follow the instructions. If that option is dimmed, obtain the update from the downloads section of the Maplesoft website.

  1. Close all programs.

Install Grid Computing Toolbox 17

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click GridComputingToolbox_WindowsX86_64.exe from the install disc.
  • From download

Double-click GridComputingToolbox_WindowsX86_64.exe from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Grid Computing Toolbox is installed to the following location:

C:\Program Files\Maple 17\toolbox\Grid

  1. When prompted, enter the name or IP address of the license server.
  1. Grid Computing Toolbox 17 is now installed. Prior to using Grid Computing Toolbox 17, you need to Configure the License Manager.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

Macintosh Installation Using a Network License

For Macintosh® Intel 32- and 64-bit installation instructions, read this section.

To install Grid Computing Toolbox 17 on your Macintosh operating system, read and complete the following tasks:

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the Grid Computing Toolbox files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. This product requires Maple 17 or later.

To identify your Maple release:

  1. Start Maple.
  1. From the Help menu, select About Maple. The About Maple 17 dialog indicates the release number.

To update to the latest Maple release:

From the Tools menu, select Check for Updates and follow the instructions. If that option is dimmed, obtain the update from the downloads section of the Maplesoft website.

  1. Close all programs.

Install Grid Computing Toolbox 17

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and double-click GridComputingToolbox_Mac.dmg from the install disc, then double-click GridComputingToolbox_Mac.
  • From download

Double-click GridComputingToolbox_Mac.dmg from where you downloaded the file, then double-click GridComputingToolbox_Mac.

  1. Follow the on-screen instructions.

By default, Grid Computing Toolbox is installed to the following location:

/Library/Frameworks/Maple.framework/Versions/17/toolbox/Grid

  1. When prompted, enter the name or IP address of the license server.
  1. Grid Computing Toolbox 17 is now installed. Prior to using Grid Computing Toolbox 17, you need to Configure the License Manager.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

32-bit Linux Installation Using a Network License

During the installation, you will need your purchase code, generally sent to you in an email.

To install Grid Computing Toolbox 17 on your 32-bit Linux® operating systems, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the Grid Computing Toolbox files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. This product requires Maple 17 or later.

To identify your Maple release:

  1. Start Maple.
  1. From the Help menu, select About Maple. The About Maple 17 dialog indicates the release number.

To update to the latest Maple release:

From the Tools menu, select Check for Updates and follow the instructions. If that option is dimmed, obtain the update from the downloads section of the Maplesoft website.

  1. Close all programs.

Install Grid Computing Toolbox 17

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run GridComputingToolbox_Linux.bin from the install disc
  • From download

Run GridComputingToolbox_Linux.bin from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Grid Computing Toolbox is installed to the following location:

$HOME/maple17/toolbox/Grid

  1. When prompted, enter the name or IP address of the license server.
  1. Grid Computing Toolbox 17 is now installed. Prior to using Grid Computing Toolbox 17, you need to Configure the License Manager.

Shortcuts for Desktop and Applications menus

During installation, a maple17.desktop file is created in the bin directory of your Grid Computing Toolbox 17 installation. If you request the installer to have a shortcut placed on your desktop, this file is also created in the ~/Desktop directory. If you wish to have a shortcut placed in your Applications menu, the maple17.desktop file can be copied to /usr/share/applications (which may require root access) or ~/.local/share/applications.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

64-bit Linux Installation Using a Network License

To install Grid Computing Toolbox 17 on your 64-bit Linux® operating systems, read and complete the following tasks.

During the installation, you will need your purchase code, generally sent to you in an email.

To install Grid Computing Toolbox 17 on your 32-bit Linux® operating systems, read and complete the following tasks.

Pre-Installation Instructions

  1. Check the System Requirements for your operating system.
  1. Logon as an administrator or log on to an account, with appropriate read and write privileges, that will own the Grid Computing Toolbox files.
  1. Ensure that you are connected to the Internet. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  1. This product requires Maple 17 or later.

To identify your Maple release:

  1. Start Maple.
  1. From the Help menu, select About Maple. The About Maple 17 dialog indicates the release number.

To update to the latest Maple release:

From the Tools menu, select Check for Updates and follow the instructions. If that option is dimmed, obtain the update from the downloads section of the Maplesoft website.

  1. Close all programs.

Install Grid Computing Toolbox 17

  1. Ensure that you have reviewed the Pre-installation Instructions.
  1. Choose one of the following two options to launch the installer:
  • From DVD
  1. Place the install disc in the DVD-ROM drive.
  1. Locate and run GridComputingToolbox_LinuxX86_64.bin from the install disc.
  • From download

Run GridComputingToolbox_LinuxX86_64.bin from where you downloaded the file.

  1. Follow the on-screen instructions.

By default, Grid Computing Toolbox is installed to the following location:

$HOME/maple17/toolbox/Grid

  1. When prompted, enter the name or IP address of the license server.
  1. Grid Computing Toolbox 17 is now installed. Prior to using Grid Computing Toolbox 17, you need to Configure the License Manager.

Shortcuts for Desktop and Applications menus

During installation, a maple17.desktop file is created in the bin directory of your Grid Computing Toolbox 17 installation. If you request the installer to have a shortcut placed on your desktop, this file is also created in the ~/Desktop directory. If you wish to have a shortcut placed in your Applications menu, the maple17.desktop file can be copied to /usr/share/applications (which may require root access) or ~/.local/share/applications.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

Configure the License Manager

Configure the License Manager for Windows

Before starting the Windows Network version of Grid Computing Toolbox 17, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and Activation Utilities

  1. Double-click NetworkToolsInstaller_Windows.exe from the DVD or from where you downloaded the file.
  1. Close all programs, particularly Microsoft® Excel and any previous release of Grid Computing Toolbox.
  1. Follow the on-screen instructions.

Activate a Network License

Grid Computing Toolbox 17 requires a Grid Computing Toolbox 17 license file to operate. License files for earlier versions of Grid Computing Toolbox do not work with Grid Computing Toolbox 17. To obtain your license file, you must use the Grid Computing Toolbox activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. From the Start menu, select (All) Programs>Maple Network Tools>Activate Grid Computing Toolbox. Notes:
  • If you are using Windows Vista or Windows 7, right-click Activate Grid Computing Toolbox and select Run as administrator.
  • If you are using Windows 8,right click anywhere in the Start window. The toolbar opens at the bottom of the screen. Next, click the All apps icon. Under the Maple 17 heading, right click on the Activate Maple 17 tile. Next, click the Run as administrator icon.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  1. A license file, Grid17.lic, will be saved to the C:\Program Files\Maple Network Tools\activate folder. You will need this license file in the next step.

Start the License Manager for Grid Computing Toolbox 17 Only

The C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows directory contains license manager daemons (lmgrd and Grid Computing Toolboxlmg) required to run Grid Computing Toolbox, as well as utilities to assist you in installing and configuring FlexNet Publisher for your system.

Start the License Manager Daemons

If you intend to use a NovellREGISTERED server, see Novell Networks.

To set up and start the license manager daemons on a Windows Network Server:

  1. From the Start menu, select (All) Programs>Maple Network Tools>LMTools11.7. Note: If you are using Windows 8, right click anywhere in the Start window to display the toolbar at the bottom of the window. Click the All apps icon. Under the Maple Network Tools heading, click LMTools11.7
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab.
  1. In the Config Services property sheet, enter or browse to the following files:

Service Name

Enter a name for the service (optional)

Path to the lmgrd.exe file

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

Path to the license file

C:\Program Files\Maple Network Tools\activate\Grid17.lic

Path to the debug log file Enter the path to the directory containing the debug log file. You must create this file manually (log.txt is the manually created file in the example below), as it is not automatically generated.

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows XP, Windows Vista and Windows 7
  1. To start the daemons at boot time (recommended), select the Start Server at Power Up check box
  1. Click Save Service. When prompted to save the service, click Yes
  1. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons

You can now use Grid Computing Toolbox 17

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Note: Maple 17 and associated toolbox licensing is compatible with licensing for Maple 14 and later, but not with licensing for versions previous to Maple 14. Maple and toolboxes earlier than version 14 need to be running the Maple 13 version of the Maple Network Tools.

Complete the following tasks:

Stop the License Manager
  1. Go to the directory of the FlexNet Publisher utilities that are currently being used and double-click lmtools.exe. Alternatively, in the Start menu, select (All) Programs>Maple Network Tools>LMTools11.7 Note: If you are using Windows 8, right click anywhere in the Start window to display the toolbar at the bottom of the window. Click the All apps icon. Under the Maple Network Tools heading, click LMTools11.7
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab. From the Server Name list, select the service currently being used.
  1. Click the Start/Stop/Reread tab, then click Stop Server.
Move all Grid Computing Toolbox License Files to a Common Directory

Using Windows Explorer, move all of the license files to a common directory, for example, C:\Program Files\Maple Network Tools\activate.

Start the License Manager Daemons
  1. From the Start menu, select (All) Programs>Maple Network Tools >LMTools11.7. Note: If you are using Windows 8, right click anywhere in the Start window to display the toolbar at the bottom of the window. Click the All apps icon. Under the Maple Network Tools heading, click LMTools11.7
  1. Under the Service/License File tab, click Configuration using Services.
  1. Click the Config Services tab.
  1. In the Config Services property sheet, enter or browse for the following:

Service Name

Enter a name for the service (optional)

Path to the lmgrd.exe file

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe

Path to the license file Note: The path to the license file should not contain a terminating backslash

C:\Program Files\Maple Network Tools\activate

Path to the debug log file Enter the path to the directory containing the debug log file. You must create this file manually (log.txt is the manually created file in the example below), as it is not automatically generated.

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt

  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows 2003, XP, Vista and 7.
  1. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  1. Click Save Service. When prompted to save the service, click Yes.
  1. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons.

You can now use your network licensed Maplesoft products.

Novell Networks

FlexNet Publisher does not run on Novell or IPX/SPX. Follow these instructions to install the license manager on any network that is exclusively a Novell environment.

  1. Install TCP/IP on all client machines.
  1. Select a Windows computer that has TCP/IP installed to act as a license server and run the license daemons using the Start License Manager for Grid Computing Toolbox 17 Only instructions.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

Configure the License Manager for Mac OS X

Before starting the Mac OSREGISTERED X Network version of Grid Computing Toolbox 17, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and the Activation Utilities

  1. To begin installing the FlexNet Publisher and Activation Utilities, choose one of the following:
  1. Place the Grid Computing Toolbox 17 DVD in the DVD-ROM drive.
  1. Double-click NetworkToolsInstaller_Mac.dmg from where you downloaded the file.
  1. Run the installer by double-clicking the NetworkToolsInstaller_Mac icon.
  1. Follow the on-screen instructions.

Activate a Network License

Grid Computing Toolbox 17 requires a Grid Computing Toolbox 17 license file to operate. License files for earlier versions of Grid Computing Toolbox do not work with Grid Computing Toolbox 17. To obtain your license file, you must use the Grid Computing Toolbox activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. From the Finder, open a terminal window from Applications -> Utilities.
  1. Change to the location of the activation utility directory. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.
  1. Run the activation script by issuing the command ./activation. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete
  1. When prompted, enter the name or IP address of the license server.
  1. A license file, Grid17.lic, will be saved to the /Users/<username>/Applications/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for Grid Computing Toolbox 17 Only

Start the License Manager Daemons

Before you can use Grid Computing Toolbox 17, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/.
  1. Start the license manager daemons
  1. To start the license manager daemon (lmgrd), enter the following command at the prompt:

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, /Users/<username>/Applications/Maple_Network_Tools/activate/Grid17.lic), and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Help for Starting the License Server

If you have any problems starting the license server in the system boot up files, refer to http://www.flexerasoftware.com

You can now use Grid Computing Toolbox 17

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Note: Maple 17 and associated toolbox licensing is compatible with licensing for Maple 14 and later, but not with licensing for versions previous to Maple 14. Maple and toolboxes earlier than version 14 need to be running the Maple 13 version of the Maple Network Tools.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For Grid Computing Toolbox 17, the default location is /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/. Enter the command:

./lmdown

Move all Grid Computing Toolbox License Files to a Common Directory

Copy all the Grid Computing Toolbox network license files to /Users/<username>/Applications/Maple_Network_Tools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/.
  1. When starting license manager daemons, you must enter the path to the directory containing all license files. By default, /Users/<username>/Applications/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

Configure the License Manager for UNIX and Linux

Before starting the UNIX Network version of Grid Computing Toolbox 17, you must obtain your license file and start the license manager by completing the following tasks.

  1. Choose one of the following:

Install FlexNet Publisher and the Activation Utilities

  1. Choose one of the following:
  1. On Linux 32-bit, run the NetworkToolsInstaller_Linux.bin file from the DVD or from where you downloaded the file.
  1. On Linux 64-bit, run the NetworkToolsInstaller_LinuxX86_64.bin file from the DVD or from where you downloaded the file.
  1. On Solaris, run the NetworkToolsInstaller_Sun.bin file from the DVD or from where you downloaded the file.
  1. Follow the on-screen instructions.

Activate a Network License

Grid Computing Toolbox 17 requires a Grid Computing Toolbox 17 license file to operate. License files for earlier versions of Grid Computing Toolbox do not work with Grid Computing Toolbox 17. To obtain your license file, you must use the Grid Computing Toolbox activation program or activate off-line by following the instructions at http://www.maplesoft.com/contact/webforms/offlineactivation/. Ensure that you can connect to the Internet as activation requires an Internet connection. If your computer does not have an Internet connection, please contact Maplesoft customer service.

  1. Change to the location of the activation utility directory. By default, $HOME/Maple_Network_Tools/activate.
  1. Run the activation command. To launch activation in console mode, use the -console option.
  1. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  1. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is completed.
  1. A license file, Grid17.lic, will be saved to the $HOME/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for Grid Computing Toolbox 17 Only

Start the License Manager Daemons

Before you can use Grid Computing Toolbox 17, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/.
  1. Start the license manager daemons.

Using the C Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt,

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, $HOME/Maple_Network_Tools/activate/Grid17.lic) and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Using the Korn or Bourne Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt:

nohup lmgrd -c license_file_path -l debug_log 2>&1 &

Run Daemons on Startup

To have the daemons run on startup, edit the appropriate boot script (such as /etc/rc.boot, /etc/rc.local, or /etc/rc2.d/Sxxxx). For example, if you run lmgrd as a boot startup script, you can run it as a regular user by using the following su command at the prompt:

su username -c \'umask 022; lmgrd_path -c license_file_path -l log_path\'

where username is a non-privileged user; lmgrd_path is the correct path to the lmgrd file, license_file_path is the full path of the network license file (by default, $HOME/Maple_Network_Tools/activate/Grid17.lic), and log_path is the debug log file path. It is recommended that the network license file be called Grid17.lic.

Help for Starting the License Server

If you have any problems starting the license server in the UNIX system boot up files, refer to http://www.flexerasoftware.com/.

You can now use Grid Computing Toolbox 17.

Start the License Manager for Multiple Maplesoft Products

To run Maple and associated products, you must place all license files in the same directory. If you have other FlexNet Publisher license files stored in one central location, you can store Maple and associated product license files there as well.

Note: Maple 17 and associated toolbox licensing is compatible with licensing for Maple 14 and later, but not with licensing for versions previous to Maple 14. Maple and toolboxes earlier than version 14 need to be running the Maple 13 version of the Maple Network Tools.

Complete the following tasks:

Stop the License Manager

Go to the location of the FlexNet Publisher utilities that are currently being used. For Grid Computing Toolbox 17, the default location is /usr/local/Maple_Network_Tools/FLEXlm/11.7/. Enter the command:

./lmdown
Move all Grid Computing Toolbox License Files to a Common Directory

Copy all of the Grid Computing Toolbox network license files to one folder, for example, $HOME/Maple_Network_Tools/activate.

Start the License Manager Daemons
  1. Navigate to the location of the FlexNet Publisher utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/11.7/.
  1. When starting license manager daemons, you must enter the path to the directory containing all of your license files. By default, $HOME/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

Named Network Licensing

Named Network Users run Grid Computing Toolbox on their own client machines. These client machines are connected to the license server over the network. The Network Named User licensing option allows system administrators to strictly enforce which users, or client machines, may run Grid Computing Toolbox.

When you install Maple Network Tools, an options file (.opt) is automatically created in the $Maple Network Tools/activate directory.

Note: The vendor daemon, maplelmg.opt, by default, looks for the options file with in the same directory that contains the license file used by the license server manager.

Setting Up Named Network Licensing

To set up Named Network User licensing, perform the following steps:

Edit the Options File

To manually edit the options file, perform the following steps:

  • Go to the directory that contains the options file. By default, this is $Maple Network Tools/activate.
  • INCLUDE lines in an options file state which users can run the product. Add an INCLUDE line for each product. If there is more than one user per product, add an INCLUDE line for each user, as well. Alternatively, you can use the GROUP syntax to combine authorized Named Users for a specific product.
Example 1: Specifying which users can run Maple 17 and Grid Computing Toolbox 17

INCLUDE Maple USER User1

INCLUDE Maple USER User2

INCLUDE Maple USER User3

INCLUDE Maple USER User4

INCLUDE MapleExcel USER User4

INCLUDE Grid17 USER User4

Example 2: Using GROUP syntax to specify users that can run Maple 17 and Grid Computing Toolbox 17

GROUP Maple_users User1 User2 User3 User4

INCLUDE Maple GROUP Maple_users

INCLUDE MapleExcel USER User4

INCLUDE Grid17 USER User4

Restart the License Manager.

You must restart the license manager for the changes to the options file to take effect.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

How to Configure the Grid Computing Toolbox

The default settings are stored in the file:

  • <maple>/toolbox/Grid/conf/grid.properties

The properties file contains settings in the format key=value where the possible keys are listed as follows:

Note: Commenting out a parameter using the # character will cause the default value for that key to be used.

Grid Computing Toolbox Configuration Settings

Key

Description

Default

grid.broadcast

The IP address mask that will define an Internet subnet. A Grid Server, when running, will broadcast its availability using UDP broadcasts. The mask determines which machines it will broadcast to. For example if all Grid Servers are on IP addresses 10.10.50.x, then a suitable mask will be 10.10.50.255. This will cause a message to be sent to every machine on the 10.10.50. network. If machines are distributed over a wider IP range, such as 10.10.50.x, 10.10.55.x, and 10.10.90.x, then a mask of 10.10.255.255 must be used to send to all 10.10.x.y addresses.

10.10.255.255

grid.broadcastport

The UDP AutoDiscovery port that each server will broadcast on to find other Grid servers. To turn off UDP AutoDiscovery, set the port to zero (0).

4400

grid.broadcastdelay

The time in seconds between UDP messages.

60

grid.debug

This controls whether extra information is written to the log files.

false

grid.DeadlockDelay

The time, in seconds, the running nodes can be stalled during an ongoing computation. While a computation is in progress, the Master node, node 0, will query the state of executing nodes. If any node fails to indicate progress over a period longer than this parameter, the grid computations will be halted and an error returned. This parameter must be in the range 1 to 60 seconds.

10

grid.license

The path to the Grid license file. If the path is a relative path, such as the default value license/Grid.dat, then it is taken relative to the Grid Computing Toolbox directory.

license/Grid.dat

grid.logfile

The path to a file to receive logging information. If the path is a relative path, such as logs/logging.txt, then it is taken relative to the Grid Computing Toolbox directory. Windows Vista Note: Users of Vista should read the note following this Table.

logs/gridlog.txt

grid.nodes

The name of file that lists the names of Grid servers, one per line to be used when Maple code is submitted by the launcher script. Generally this name should be left blank in the properties file and specified on the command line. See Batch processing in the Maple Help System for details on how the node list is used.

 

grid.numcpus

The number of CPUs to use on this machine. Specifying a value less than 1 will cause the system to attempt to query the machine for the number of CPUs and assign a node for each.

1

grid.maple

The full path to the command-line version of Maple to be used by the grid node(s) on this machine. For example, on Linux, it would be set to /usr/local/maple/bin/maple. This path is set by the installer and should not be altered.

 

grid.port

The port that the server on this machine will use to receive messages from other nodes via the Send and Receive commands. If more than 1 CPU is being used, numcpus > 1, then CPU 0 will use this port, CPU 1 will use port + 1, CPU 2 will use port +2, etc.

2000

Windows Vista Note: In order to get logging to work on Vista, you need to either:

  • change permissions on the <maple>\toolbox\Grid\logs directory so that it is writeable
  • change the grid.logfile parameter in the configuration file to point to an absolute filename (eg. C:\temp\gridlog.txt) that is in a directory that is writeable.

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

Getting Started With Grid Computing Toolbox 17

Windows

  • Double-click the Grid Computing shortcut on your desktop.

Linux and Solaris

  1. Start Maple 17 (Standard interface).
  1. Open the file <maple>/toolbox/Grid/worksheets/GridComputing.mw.

Macintosh

  • Double-click the Grid Computing shortcut on your desktop

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

System Requirements

32-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows XP

Intel Pentium III 650 MHz or higher or fully compatible

2 GB

2 GB

Windows Vista

Intel Pentium III 1 GHz

2 GB

2 GB

Windows Server 2008 R2

x86_64 1.4 GHz (single core) or x86_64 1.3 GHz (dual core) or equivalent

2 GB

2 GB

Windows 7

Intel Pentium III 1 GHz

2 GB

2 GB

Windows Server 2012

x86_64 1.4 GHz (single core) or x86_64 1.3 GHz (dual core) or equivalent

2 GB

2 GB

Windows 8

Intel Pentium III 1 GHz

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.

64-bit Windows System Requirements

Version

CPU

Recommended RAM

Hard Disk

Windows XP

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Vista

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Server 2008 R2

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows 7

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows Server 2012

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

Windows 8

AMD X86_64 1 GHz Intel Xeon, Intel 64

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

Macintosh System Requirements

Vendor

CPU

Operating System

Version

Recommended RAM

Hard Disk

Apple

64-bit Intel

OS X

10.6, 10.7, 10.8

2 GB

2 GB

  • Java™ Runtime Environment 1.6.0_18 or higher installed
  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform.

32-bit Linux System Requirements

Vendor

Operating System Version

CPU

Recommended RAM

Hard Disk

Red Hat Enterprise Linux

5, 6

Intel Pentium III 650 MHz or equivalent

2 GB

2GB

SUSE Linux Enterprise Desktop

11, 12

Intel Pentium III 650 MHz or equivalent

2 GB

2 GB

Ubuntu

12.04 LTS, 12.10

Intel Pentium III 650 MHz or equivalent

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.

64-bit Linux System Requirements

Vendor

Operating System Version

CPU

Recommended RAM

Hard Disk

Red Hat Enterprise Linux

5, 6

Intel 64 or AMD X86_64

2 GB

2 GB

SUSE Linux Enterprise Desktop

11, 12

Intel 64 or AMD X86_64

2 GB

2 GB

Ubuntu

12.04 LTS, 12.10

Intel 64 or AMD X86_64

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform

Solaris System Requirements

Vendor

Hardware

Operating System

Version

Recommended RAM

Hard Disk

Oracle

SPARC

Solaris

10

2 GB

2 GB

  • DVD-ROM drive (for DVD installation).
  • 16-bit color at 1024 by 768 (or greater) resolution recommended.
  • X11 R6.
  • Internal TCP/IP connections enabled.
  • System performance may be affected if running below the recommended memory requirement.
  • Classic Worksheet is not available on this platform

Return to the top of the Grid Computing Toolbox 17 Installation and Licensing Guide.

Trademarks

Note: Maple uses the Flexera Software Corporation FlexNet Publisher as its license manager. This document contains all the information you require for a standard Maple installation. For more information, refer to the FlexNet Publisher documentation at http://www.flexerasoftware.com/.

Maple, Maplesoft, and Waterloo Maple are trademarks of Waterloo Maple Inc.

Intel is a registered trademark of Intel Corporation.

Microsoft, Windows, Windows Server, Windows Vista, Excel, and Internet Explorer are registered trademarks of Microsoft Corporation.

Macintosh and Mac OS are registered trademarks of Apple Computer, Inc.

NVIDIA is a registered trademark of NVIDIA Corporation.

Java, JRE, and Solaris are registered trademarks of Oracle and/or its affiliates.

FLEXlm is a trademark of Flexera Software Corporation Corporation.

Linux is a registered trademark of Linus Torvalds.

All other brand names or product names are trademarks or registered trademarks of their respective companies.