Maple 16 Installation and Licensing Guide


Maple 16 インストールとライセンシングの手引き
シングルユーザライセンスの場合の Maple 16 のインストール
シングルユーザ・バージョンのアクティベーション
Maple 16 ネットワークライセンスを用いたインストール
Windows 上のサイレント・インストール
Maple Toolbox のインストール
OpenWatcom (Windows 32 ビットのみ)
Microsoft Visual C++ コンパイラーのインストール・設定
ビデオカード・ドライバーの仕様の確認
ライセンスマネージャの設定
指名ネットワークライセンシング
Maple の起動方法
Maple のカスタマイズ方法
Maple-NAG® Connector の使用方法
システム仕様
商標

Maple 16 インストールとライセンシングの手引き

シングルユーザライセンスの場合の Maple 16 のインストール

32-bit Windows におけるシングルユーザ用インストール

Windows® XP、Windows Server® 2008、Windows Vista®、および Windows® 7 におけるシングルユーザー用インストールについては、この節を参照してください。64 ビット Windows におけるインストールについては、64 ビット Windows シングルユーザ用インストール を参照してください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

Maple 16 を Windows オペレーティングシステム上にインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc の Windows/Disk1/InstData/VM/Maple16WindowsInstaller_ja.exe をダブルクリックしてください。
  • ダウンロードによる方法

ダウンロード先より Maple16WindowsInstaller_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると Maple 16 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

Maple 16 Installation and Licensing Guideの先頭に戻る

64 ビット Windows シングルユーザ用インストール

注意: Maple を 64 ビット Microsoft® Windows 環境で使用する場合、Maple コンパイラーを使用するためには Microsoft® Visual C++ コンパイラーをインストール・設定する必要があります。Microsoft Visual C++ コンパイラーを Maple で使用するための設定方法については Microsoft Visual C++ コンパイラーのインストール・設定 をご覧ください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

Maple 16 を Windows オペレーティングシステム上にインストールするには、次の手順に従ってください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

Maple 16 を Windows オペレーティングシステム上にインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から Windows64/Disk1/InstData/VM/Maple16WindowsX86_64Installer_ja.exe を見つけてダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で Maple16WindowsX86_64Installer_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると Maple 16 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

Maple 16 Installation and Licensing Guideの先頭に戻る

Macintosh シングルユーザ用インストール

Macintosh® PowerPC と Intel の、32 ビットおよび 64 ビットのシングルユーザ用インストール方法は、本セクションを参照してください。

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

Maple 16 を Macintosh オペレーティングシステムにインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から Maple16MacInstaller_ja.dmg を見つけてダブルクリックし、その次に Maple16MacInstaller をダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で Maple16MacInstaller_ja.dmg をクリックし、その次に Maple16MacInstaller をダブルクリックしてください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると Maple 16 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

Maple 16 Installation and Licensing Guideの先頭に戻る

32 ビット Linux のシングルユーザ用インストール

インストール中、パーチェスコードが必要となります。これは、通常 E メールでお送りします。

32 ビット Linux® オペレーティングシステムに Maple 16 をインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から Linux/Disk1/InstData/VM/Maple16Linux32Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から Maple16Linux32Installer.bin を実行してください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると Maple 16 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

デスクトップおよびアプリケーションメニュー用ショートカット

インストールの際、maple16.desktop ファイルがユーザーの Maple 16 インストールの bin ディレクトリに作成されます。デスクトップにショートカットを作成するように指定した場合、~/Desktop ディレクトリにもこのファイルが作成されます。ユーザーのアプリケーションメニューにショートカットを作成したい場合は、maple16.desktop ファイルを /usr/share/applications (ルート権限が必要) または ~/.local/share/applications にコピーします。

Maple 16 Installation and Licensing Guideの先頭に戻る

64 ビット Linux のシングルユーザー用インストール

インストールの途中でパーチェスコードが必要となります。これは通常メールで送られます。

64 ビット Linux® オペレーティングシステム上に Maple 16 をインストールする際には、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から X86_64/Disk1/InstData/VM/Maple16LinuxX86_64Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から Maple16LinuxX86_64Installer.bin を実行してください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、シングルユーザライセンス を選択します。
  1. プロンプトされたら、パーチェスコードと必要な情報を入力し、アクティベーションを終了してください。
  1. アクティベーションに成功すると Maple 16 を使用開始できます。アクティベーション中に問題が発生したり、インストール中にアクティベーションしないことを選択した場合は シングルユーザ・バージョンのアクティベーション をご覧ください。

デスクトップおよびアプリケーションメニュー用ショートカット

インストールの際、maple16.desktop ファイルがユーザーの Maple 16 インストールの bin ディレクトリに作成されます。デスクトップにショートカットを作成するように指定した場合、~/Desktop ディレクトリにもこのファイルが作成されます。ユーザーのアプリケーションメニューにショートカットを作成したい場合は、maple16.desktop ファイルを /usr/share/applications (ルート権限が必要) または ~/.local/share/applications にコピーします。

Maple 16 Installation and Licensing Guideの先頭に戻る

シングルユーザ・バージョンのアクティベーション

Maple 16 以降では、操作するのに Maple 16 ライセンスファイルが必要です。それより前の Maple バージョンのライセンスファイルは Maple 16 では動作しません。ライセンスファイルを取得するには、シングルユーザーバージョンの Maple 16 をアクティベートする必要があります。シングルユーザー用のインストーラを実行している場合は、インストール中にアクティベーションを行うことができます。インストール中に行わなかった場合は、次の手順でアクティベーションを実行します。

  1. アクティベーションにはインターネット接続が必要です。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. スタンダードワークシート Maple 16 を起動します。
  1. アクティベーションのプロンプトが出たら、アクティベーション をクリックしてください。
  1. パーチェスコード入力のプロンプトが表示されます。プロキシサーバーを介してアクティベーションを行う場合、次へ をクリックする前に情報を入力するように注意してください。
  1. その他の情報を入力するプロンプトが表示されます。入力が完了したら 次へ をクリックしてください。
  • Windows では、スタートメニューのショートカット (すべての)プログラム>Maple 16>Tools>Activate Maple 16 よりアクティベーションを行うこともできます。注意: Windows Vista または Windows 7 を使用している場合は、Activate Maple 16 を右クリックし、管理者として実行 を選択してください。
  • Linux では、activation スクリプトを実行してアクティベートすることもできます。このスクリプトはユーザーの Maple 16 インストールの bin ディレクトリにあります。
  • Macintosh では、activation スクリプトを実行してアクティベートすることもできます。このスクリプトはユーザーの Maple 16 インストールの bin フォルダにあります。デフォルトでは、 /Library/Frameworks/Maple.framework/Versions/16/bin にあります。

Maple 16 ライセンスファイル (license.dat) はユーザーの Maple 16 インストールのライセンスフォルダに保存されます。アクティベーションで問題が発生した場合は、FAQ ページ (http://www.maplesoft.com/support/Faqs/Activation) を参照してください。

Maple 16 Installation and Licensing Guideの先頭に戻る

Maple 16 ネットワークライセンスを用いたインストール

ネットワークライセンスを用いた 32 ビット Windows 上のインストール

Windows XP、Windows Server 2008、Windows Vista、および Windows 7 におけるネットワークライセンスを使用したインストールについては、この節を参照してください。64 ビット Windows の場合は、ネットワークライセンスを用いた 64 ビット Windows 上のインストール を参照してください。

ネットワークライセンスを用いて Windows オペレーティングシステム上に Maple 16 をインストールする場合は、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc の Windows/Disk1/InstData/VM/Maple16WindowsInstaller_ja.exe をダブルクリックしてください。
  • ダウンロードによる方法

ダウンロード先より Maple16WindowsInstaller_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. Maple 16 のインストールが完了しました。Maple 16 を使用する前に、ライセンスマネージャの設定 が必要となります。

Maple 16 Installation and Licensing Guideの先頭に戻る

ネットワークライセンスを用いた 64 ビット Windows 上のインストール

注意: Maple を 64 ビット Microsoft® Windows 環境で使用する場合、Maple コンパイラーを使用するためには Microsoft® Visual C++ コンパイラーをインストール・設定する必要があります。Microsoft Visual C++ コンパイラーを Maple で使用するための設定方法については Microsoft Visual C++ コンパイラーのインストール・設定 をご覧ください。

ネットワークライセンスを用いて Windows オペレーティングシステム上に Maple 16 をインストールする場合は、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から Windows64/Disk1/InstData/VM/Maple16WindowsX86_64Installer_ja.exe を見つけてダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で Maple16WindowsX86_64Installer_ja.exe をダブルクリックしてください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. Maple 16 のインストールが完了しました。Maple 16 を使用する前に、ライセンスマネージャの設定 が必要となります。

Maple 16 Installation and Licensing Guideの先頭に戻る

Macintosh シングルユーザ用インストール

Macintosh® PowerPC と Intel の、32 ビットおよび 64 ビットのシングルユーザ用インストール方法は、本セクションを参照してください。

Maple 16 を Macintosh オペレーティングシステムにインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から Maple16MacInstaller_ja.dmg を見つけてダブルクリックし、その次に Maple16MacInstaller をダブルクリックしてください。
  • ダウンロードによる方法

ファイルのダウンロード先で Maple16MacInstaller_ja.dmg をクリックし、その次に Maple16MacInstaller をダブルクリックしてください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. Maple 16 のインストールが完了しました。Maple 16 を使用する前に、ライセンスマネージャの設定 が必要となります。

Maple 16 Installation and Licensing Guideの先頭に戻る

ネットワークライセンスを用いた 32 ビット Linux 上のインストール

32 ビット Linux® オペレーティングシステムに Maple 16 をインストールするには、次の手順に従ってください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から Linux/Disk1/InstData/VM/Maple16Linux32Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から Maple16Linux32Installer.bin を実行してください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. Maple 16 のインストールが完了しました。Maple 16 を使用する前に、ライセンスマネージャの設定 が必要となります。

注意: Maple 14 以降、Maple で使用されるライセンス管理ソフトウェアである FlexNet の要件として、Linux システムが LSB 3.0 でなければならなくなりました。このため、いくつかの追加パッケージをインストールする必要があります。Linux 上で Maple をアクティベートするときに "Error detecting HostID" というエラーメッセージが表示される場合は、適切なパッケージがインストールされていることを確認してください。

  • Ubuntu では、lsb ベースおよび lsb コアのパッケージがインストールされていることを確認してください。lsb コアパッケージはデフォルトではインストールされません。
  • Red Hat では、redhat-lsb パッケージがインストールされていることを確認してください。
  • SUSE では、lsb パッケージがインストールされていることを確認してください。このパッケージはデフォルトではインストールされません。

デスクトップおよびアプリケーションメニュー用ショートカット

インストールの際、maple16.desktop ファイルがユーザーの Maple 16 インストールの bin ディレクトリに作成されます。デスクトップにショートカットを作成するように指定した場合、~/Desktop ディレクトリにもこのファイルが作成されます。ユーザーのアプリケーションメニューにショートカットを作成したい場合は、maple16.desktop ファイルを /usr/share/applications (ルート権限が必要) または ~/.local/share/applications にコピーします。

Maple 16 Installation and Licensing Guideの先頭に戻る

ネットワークライセンスを用いた 64 ビット Linux 上のインストール

64 ビット Linux® オペレーティングシステム上に Maple 16 をインストールする際には、次の手順を読んで実行してください。

インストール前の手順

  1. オペレーティングシステムの システム仕様 を確認してください。
  1. 適切な読み書きの権限を持ち、Maple の諸ファイルを所有するアカウントにログオンするか、管理者としてログオンします。
  1. インターネットに接続していることを確認してください。インターネット接続のないコンピュータを使用する場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. ビデオカード・ドライバーの仕様を確認してください。詳細は ビデオカード・ドライバーの仕様の確認 をご覧ください。
  1. すべてのプログラムを閉じてください。

Maple 16 をインストール

  1. インストール前の手順を必ず読んでください。
  1. インストーラーを起動するため次の 2 つのオプションのひとつを選択してください。
  • DVD から
  1. install disc を DVD-ROM ドライブに入れてください。
  1. install disc から X86_64/Disk1/InstData/VM/Maple16LinuxX86_64Installer.bin を見つけて実行してください。
  • ダウンロードによる方法

ファイルのダウンロード先から Maple16LinuxX86_64Installer.bin を実行してください。

  1. 画面の指示に従ってください。

注意: MATLAB® 2010b または 2011a をインストールしていて、Maple に接続するツールボックスを MATLAB にインストールしたい場合は、Maple Toolbox のインストール を参照してください。

  1. ライセンスタイプを選択 の画面から、ネットワークライセンス を選んでください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. Maple 16 のインストールが完了しました。Maple 16 を使用する前に、ライセンスマネージャの設定 が必要となります。

注意: Maple 14 以降、Maple で使用されるライセンス管理ソフトウェアである FlexNet の要件として、Linux システムが LSB 3.0 でなければならなくなりました。このため、いくつかの追加パッケージをインストールする必要があります。Linux 上で Maple をアクティベートするときに "Error detecting HostID" というエラーメッセージが表示される場合は、適切なパッケージがインストールされていることを確認してください。

  • Ubuntu では、lsb ベースおよび lsb コアのパッケージがインストールされていることを確認してください。lsb コアパッケージはデフォルトではインストールされません。
  • Red Hat では、redhat-lsb パッケージがインストールされていることを確認してください。
  • SUSE では、lsb パッケージがインストールされていることを確認してください。このパッケージはデフォルトではインストールされません。

デスクトップおよびアプリケーションメニュー用ショートカット

インストールの際、maple16.desktop ファイルがユーザーの Maple 16 インストールの bin ディレクトリに作成されます。デスクトップにショートカットを作成するように指定した場合、~/Desktop ディレクトリにもこのファイルが作成されます。ユーザーのアプリケーションメニューにショートカットを作成したい場合は、maple16.desktop ファイルを /usr/share/applications (ルート権限が必要) または ~/.local/share/applications にコピーします。

Maple 16 Installation and Licensing Guideの先頭に戻る

Maple 16 Installation and Licensing Guideの先頭に戻る

Windows 上のサイレント・インストール

Windows では、サイレントモードオプションを使用して Maple のネットワークバージョンをインストールすることができます。Windows XP、2008 Server、Windows Vista、Windows 7、または 64 ビット Windows の場合は以下の手順を実行してください。リソースファイルに正確な情報が含まれていることを確認してください。

インストール前の準備

  1. Windows のシステム仕様を確認してください。
  1. プログラムをすべて閉じてください。特に、Microsoft Excel や、Maple の旧バージョンは必ず閉じるよう注意してください。
  1. 管理者としてログオンしてください。管理者権限が必要となります。
  1. リソースファイルを作成します。

コマンド Maple16WindowsInstaller_ja.exe -r <PATH>\installer.properties (32 ビット Windows) または Maple16WindowsX86_64Installer_ja.exe -r <PATH>\installer.properties (64 ビット Windows) を使用してインストーラを実行すると、リソースファイルを自動的に作成することができます。ここで、<PATH> はユーザーが指定したディレクトリです。スクリーンに表示される指示に従ってインストールを完了します。

-r フラグにより生成される installer.properties ファイルを用いるか、次の例をテンプレートとして自分のファイルを作成することもできます。

INSTALLER_UI=SILENT

#Choose Install Folder

#---------------------

USER_INSTALL_DIR=C:\Program Files\Maple 16

#Install Desktop Shortcuts

#-------------------------

DESKTOP_SHORTCUTS="Yes",""

DESKTOP_SHORTCUTS_1=Yes

DESKTOP_SHORTCUTS_2=

DESKTOP_SHORTCUTS_BOOLEAN_1=1

DESKTOP_SHORTCUTS_BOOLEAN_2=0

#Choose Watcom Install Folder

#----------------------------

WATCOM_INSTALL_FOLDER=C:\watcom-1.3

#Maple Worksheet Association

#----------------------------

WKS_ASSOC_RESULT="Yes",""

WKS_ASSOC_RESULT_1=Yes

WKS_ASSOC_RESULT_2=

WKS_ASSOC_RESULT_BOOLEAN_1=1

WKS_ASSOC_RESULT_BOOLEAN_2=0

#Choose the Type of Licensing

#----------------------------

LICENSE="","Network License"

LICENSE_1=

LICENSE_2=Network License

LICENSE_BOOLEAN_1=0

LICENSE_BOOLEAN_2=1

LICENSE server

#----------------------------

LICENSE_SERVER=myserver.mydomain.com

PORT_NUMBER=

  1. コマンド・プロンプト・ウィンドウを開く。
  1. Maple16WindowsInstaller_ja.exe または Maple16WindowsX86_64Installer_ja.exe ファイルがあるディレクトリーまで移動してください。
  1. Maple16WindowsInstaller_ja.exe -f installer.properties (32 ビット Windows)または Maple16WindowsX86_64Installer_ja.exe -f installer.properties の何れかのコマンドによりサイレント・インストーラー・プロセスを実行します。

注意: installer.properties ファイルを、Maple16WindowsInstaller_ja.exe または Maple16WindowsX86_64Installer_ja.exe ファイルの場所以外のディレクトリーに作成した場合、このコマンドを実行するとき installer.properties ファイルのパスを指定する必要があります。

注意

  1. インストール中、installer.properties ファイルを -r フラグを用いて作成した場合は、INSTALLER_UI=SILENT の行は自動的には入りません。-r を用いて installer.properties ファイルを作成した場合はファイル中の最初に INSTALLER_UI=SILENT を挿入する必要があります。
  1. このテンプレートでは、Maple 16 が C:\Program Files\Maple 16 にインストールされていることを前提としています。別の場所を指定したい場合は、USER_INSTALL_DIR を変更してください。
  1. テンプレートは、デスクトップに Maple 16 のテスクトップ・アイコンを表示することを前提としています。不要な場合は "Install Desktop Shortcuts" のセクションの各行を以下の行で置き換えてください。

DESKTOP_SHORTCUTS="","No"

DESKTOP_SHORTCUTS_1=

DESKTOP_SHORTCUTS_2=No

DESKTOP_SHORTCUTS_BOOLEAN_1=0

DESKTOP_SHORTCUTS_BOOLEAN_2=1

  1. 必要であれば、WATCOM コンパイラーの場所を変更できます。パス名に空白文字は使用できません。WATCOM_INSTALL_FOLDER フィールドを完全に削除すると、WATCOM コンパイラーはインストールされません。
  1. テンプレートは、デフォルトの Maple バージョンが Maple 16 であることを前提としています(システムには Maple の他のバージョンがインストールされていることを前提とします)。これを変更するには、"Maple Worksheet Association" セクションの各行を以下のものに置き換えてください。

WKS_ASSOC_RESULT="","No"

WKS_ASSOC_RESULT_1=

WKS_ASSOC_RESULT_2=No

WKS_ASSOC_RESULT_BOOLEAN_1=0

WKS_ASSOC_RESULT_BOOLEAN_2=1

  1. ライセンスサーバー名(必須)を変更し、ポート番号(オプション)を適宜追加

追加項目

  • このモードでインストーラーを実行すると、フィードバックは表示されません
  • Maple のシングルユーザ・バージョンをサイレントでインストールすることはできますが、その場合製品のアクティベーションは同時にできません。Maple 16 のシングルユーザ・バージョンのサイレント・インストールが完了したら、スタートメニューより すべてのプログラム を選択し、Maple 16ToolsActivate Maple 16 と選択してください。

Windows 上のサイレント・アンインストール

  1. Maple のサイレント・アンインストールを行うには、コマンドプロンプトに対して次のコマンドを実行してください。

"C:\Program Files\Maple 16\uninstall\Uninstall Maple 16.exe" -i silent

Maple 16 Installation and Licensing Guideの先頭に戻る

Maple Toolbox のインストール

MATLAB がインストールされている場合、Maple と MATLAB を統合するためのツールボックスをインストールできます。このツールボックスを使用すると、いずれの環境においても、Maple と MATLAB のすべてのコマンド、変数、関数に直接アクセスすることができます。

MATLAB バージョンの要件

Maple 16 と MATLAB との接続性は MATLAB® 2010b または 2011a でサポートされています。Maple 16 と互換性のある MATLAB バージョンの最新情報は、http://www.maplesoft.com/products/system_requirements.aspx で確認できます。上記より古い、または新しいバージョンの MATLAB でも動作する場合がありますが、Maplesoft による動作検証は行われていません。

Maple インストール時の Maple Toolbox のインストール

Maple のインストールプロセス中に、MATLAB がインストールされていることが検出されると、その旨がパネルに表示されます。このときに、使用したいバージョンの MATLAB をリストから選択することで、Maple を MATLAB に接続するツールボックスをインストールできます。または、「インストールしません」を選択して Maple Toolbox のインストールをスキップすることもできます。

MATLAB Symbolic Math Toolbox がインストールされている場合は、別のパネルが表示され、Maple Toolbox か MATLAB Symbolic Math Toolbox のどちらかを選択するように求められます。

Maple インストール後の Maple Toolbox のインストール

Maple をインストールした後で Maple Toolbox をインストールするには、以下の手順を実行します。

  • Windows の場合は、バッチファイル MapleToolbox.bat を Maple インストールのルートディレクトリで実行します。このディレクトリは、デフォルトでは C:\Program Files\Maple 16 です。スクリーンに表示される指示に従います。
  • Linux または Solaris の場合は、MapleToolbox を Maple インストールのルートディレクトリで実行します。このディレクトリは、デフォルトでは、$HOME/Maple16/ です。ここで、$HOME はユーザーのホームディレクトリです。スクリーンに表示される指示に従います。
  • Macintosh では、Maple Toolbox を Maple インストールのルートディレクトリで実行します。このディレクトリは、デフォルトでは、/Library/Frameworks/Maple.framework/Versions/16 です。スクリーンに表示される指示に従います。

Maple Toolbox をはじめる前に

MATLAB を起動して、MATLAB ヘルプシステムを開きます。メインの Maple Toolbox を開くには、目次から Maple Toolbox を選択します。

Maple 16 Installation and Licensing Guideの先頭に戻る

OpenWatcom (Windows 32 ビットのみ)

32 ビット Windows システムでは、Maple 16 に OpenWatcom C コンパイラが含まれています。このコンパイラは Maple のコンパイラ機能で使用されます。この機能により、ユーザー定義の Maple ルーチンをコンパイルし、コードの処理を高速化できます。

この機能を使用するには、Maple 16 のインストール時に OpenWatcom C コンパイラをインストールする必要があります。OpenWatcom コンパイラは、名前に空白が含まれていない場所にインストールれている必要があります (デフォルトは C:\watcom-1.3)。このデフォルトの場所は、インストール中に変更できます。

インストール後に OpenWatcom C コンパイラを削除するには、以下の手順を実行します。

  1. Watcom がインストールされているディレクトリを削除します。
  1. WATCOM 環境変数を削除します。
  1. (任意) INCLUDE 環境変数から Watcom パスを削除します。
  1. (任意) PATH 環境変数から Watcom パスを削除します。

注意: 古いバージョンの Maple で OpenWatcom コンパイラをインストールしていた場合は、同じ場所に再インストールしてください。

Maple 16 Installation and Licensing Guideの先頭に戻る

Microsoft Visual C++ コンパイラーのインストール・設定

注意: Windows Vista または Windows 7 を使用する場合、Microsoft Visual C++ コンパイラーの設定・インストールを行うには管理者権限を持ったアカウントにログインする必要があります。

必要なソフトウェアのインストール・設定を行うには、次の手順に従ってください。

Download and Install Microsoft Visual C++ Express Edition

Visual Studio C++ コンパイラの設定

Download and Install Microsoft Visual C++ Express Edition

  1. コンピューターに、以下のソフトウェアをダウンロードし、インストールしてください。
  • Microsoft Windows SDK for Windows 7 および .NET Framework 4 (http://msdn.microsoft.com/en-us/windowsserver/bb980924.aspx より無料ダウンロード)。注意: Visual C++ コンパイラー・コンポーネントを必ずインストールしてください。.NET Framework 4 はフル・インストールが必要です。
  • Microsoft Visual C++ 2010 Express Edition (無料ダウンロード)

注意: Microsoft Visual C++ 2010 Edition のダウンロード方法は次の通りです。

  1. http://www.microsoft.com/express/Downloads/ に移動してください。
  1. Visual Studio 2010 Express タブを選択します。
  1. Visual C++ 2010 Express Edition リンクをクリックします。
  1. 言語を選択してください。
  1. Free Download ボタンをクリックしてください。

Visual Studio C++ コンパイラの設定

Maple 16 のスタンダードワークシートを起動するたびに、コンピュータが自動的にスキャンされ、適切な Microsoft Visual Studio C++ コンパイラが検索されます。サポートされているコンパイラバージョンは 2010、2008、2005、および 2003 です。

サポートされているバージョンの Visual Studio C++ コンパイラが検出されない場合は、コンパイラで使用される環境変数 %LIB%%INCLUDE%、および %PATH% を手動で定義できます。または、Maple のインストール中に作成された vcvars64.bat のパスを指定することで、Maple 16 に対して Microsoft Visual C++ コンパイラを設定することもできます。vcvars64.bat のパスを指定するには、以下の手順を実行します。

  • Maple がすでにコンピューターにインストールされている場合は、Maple からコマンドを実行してファイルへのパスを指定することができます。以下の手順に従ってください。
  1. Maple を開く。
  1. Maple プロンプトより、Compiler:-Setup() と入力し、Enter を押します。
  1. ダイアログボックスで、vcvars64.bat ファイルのフルパスを指定します。
  1. Maple を閉じる。
  • 注意: Maple 16 のスタンダードワークシートバージョンを使用している場合は、Compiler:-Setup() コマンドを使用できます。Maple 16 のコマンドラインバージョンを使用している場合は、手動で %LIB%%INCLUDE%、および %PATH% 環境変数を定義する必要があります。

Maple 16 Installation and Licensing Guideの先頭に戻る

ビデオカード・ドライバーの仕様の確認

Maple 16 においてグラフィックスの性能を最適化するには、使用しているビデオカードの最新のドライバー・ソフトウェアをインストールすることを強く推奨します。Maple 16 を使用する前に、本セクションの手順に従いビデオカードのドライバー・ソフトウェアを確認し、必要であればアップグレードしてください。

ビデオカードの種類の特定

32 ビットおよび 64 ビット Windows

  1. 次の方法のうちのひとつにより、デバイスマネージャのウィンドウを開きます。
  • (Windows 2003 および XP) スタート から ファイル名を指定して実行 を選択。名前 フィールドに devmgmt.msc を入力して OK をクリック。
  • (Windows Vista および Windows 7) スタート メニューを開く。検索 フィールドに devmgmt.msc を入力し、検索を実行。検索結果から デバイスマネージャ をクリックします。
  1. デバイスマネージャ ウィンドウで ディスプレイ アダプタ のセクションを開きます。このセクションに、使用中のビデオカードの種類が表示されます(例、RADEON X600 Series など)。

32 ビット および 64 ビット の Linux と UNIX

注意: このステップは、ルート・ユーザとして、または sudo アクセスによりログインしていることが必要となります。ネットワーク・コンピューターまたはシェアド・コンピューターを使用している場合はシステム管理者に連絡してください。

  1. コマンドプロンプトが表示されたら、lspci コマンドを実行します(lspci コマンドは /sbin または /usr/sbin ディレクトリーにあるかもしれません)。
  1. 出力中、"VGA" または "Display controller" が入った行を探します。例えば、

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)

01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)

Macintosh

  1. Apple メニューより、この Mac について を選択します。
  1. 詳しい情報...をクリックします。
  1. システムプロファイラー中、左枠の ハードウェア セクションを開き、グラフィックス/ディスプレイ をクリックしてください。ウィンドウの右側パネル中 チップセットのモデル の左にビデオカードが表示されます。(例、チップセットのモデル: ATI Radeon HD 2600Pro

Maple 16 Installation and Licensing Guideの先頭に戻る

ドライバー・ソフトウェアの確認・アップグレード

32 ビットおよび 64 ビット Windows

  1. デバイスマネージャ ウィンドウ内、ディスプレイ アダプタ のセクションで、インストール先コンピューターのビデオカード名を右クリックし、ドライバの更新...を選択してください。ハードウェアの更新ウィザード が表示されます。
  1. Windows Update 接続用のプロンプトが表示されたら、はい、今回のみ接続します をクリックして 次へ をクリックしてください。
  1. ソフトウェアを自動的にインストールする(推奨) を選択して 次へ をクリックしてください。ウィザードは、現在インストールされているドライバー・ソフトウェアよりも新しいバージョンが提供されているか調べます。

最新のドライバーがインストールされていることをウィザードが検知したら、完了 をクリックしてウィザードを閉じてください。これでコンピューターは Maple 16 のグラフィックスを表示できるように設定されました。

インストールされているドライバーよりも新しいものが提供されていることをウィザードが示したら、画面の指示に従ってアップデートをインストールしてください。

32 ビット および 64 ビット の Linux と UNIX

  1. ビデオカードが使用しているドライバーのバージョンを調べてください。調べ方は ビデオカードで使われているドライバーの特定 をご覧ください。
  1. ビデオカード販売元のウェブサイトに行き、インストールされているものより新しいドライバーソフトウェアが提供されているか調べてください。「最新のドライバーソフトウェアの取得法」に記載されている手順をご覧ください。

販売元が提供する最新のドライバーソフトウェアのバージョンナンバーが、インストールされているもののバージョンナンバーと一致すれば、コンピューターが Maple 16 のグラフィックスを表示する設定が整っていることになります。より新しいバージョンがある場合は、ウェブサイトよりドライバーソフトウェアをダウンロードし、コンピューターにインストールしてください。

注意: Linux や UNIX のソフトウェア更新ユーティリティーにより自動的に検出されたソフトウェア・アップグレードの利用は推奨しません。

Macintosh

  • Apple メニューより、ソフトウェア・アップデート...を選択してください。

Software Update ウィンドウにビデオカードの更新用ドライバーソフトウェアが表示されていなければ、コンピューターに最新のバージョンがインストールされているということを意味します。このとき、コンピューターは、Maple 16 でグラフィックスを表示できる設定となっています。

更新用ドライバーソフトウェアが表示されているときは、それを選択し、インストール をクリックしてください。画面の指示に従い、インストールを完了してください。

Maple 16 Installation and Licensing Guideの先頭に戻る

販売元ウェブサイトからの、更新ドライバーのダウンロード・インストール

Linux または UNIX オペレーティングシステムを使用している場合、もしくは Windows または Macintosh オペレーティングシステムを使用していて自動的に検出されたソフトウェアが正常に動作しない場合は、ビデオカード販売元のウェブサイトから最新のドライバーをダウンロードし、インストールしてください。

ビデオカードで使われているドライバーの特定

32 ビットおよび 64 ビット Windows
  1. デバイスマネージャ ウィンドウで、ディスプレイ アダプタ セクションを開く。
  1. コンピューターのビデオカードの項目を右クリックし、プロパティ を選択します。ビデオカードに関する情報を含んだダイアログボックスが表示されます。
  1. ドライバ タブをクリックしてください。ビデオカードが使用しているドライバーのバージョンは、ウィンドウ上部の バージョン の隣に表示されています。
32 ビット および 64 ビット の Linux と UNIX

まず、グラフィックスのハードウェア・アクセラレータが有効になっているか調べてください。

  • Linux または UNIX インストール先のルートより、glxinfo | head というコマンドを実行してください。

グラフィックスのハードウェア・アクセラレータが有効になっていれば direct rendering: Yes という行が表示されます。この行が direct rendering: No であれば、ハードウェア・アクセラレータは無効になっています。

Linux または UNIX のインストールのパッケージ管理システムから、コンピュータにインストールされているドライバーを検索することができます。Linux および UNIX は、ディストリビューションにより異なるパッケージ管理システムを使用しています。以下、Linux の最も使われているディストリビューション 2 つについて手順を説明します。

dpkg ベースの Linux ディストリビューション(Ubuntu など)

システムにどのパッケージがインストールされているか調べるには、dpkg -l コマンドを実行してください(最終文字は L の小文字)。このコマンドは出力結果を数行表示するので、grep コマンドで出力量を制限すると便利です。上記の例に続き、次のコマンドで NVIDIA® ドライバーを探すことができます。

dpkg -1 | grep -i nvidia

ハードウェア・アクセラレータ対応のドライバーをインストールしてある場合、nvidia-glx-177 のような出力行が見られます。この例の場合、177 はドライバーの主要バージョンナンバーで、2 列目に完全なバージョンナンバーが表示されます。例えば、Ubuntu システムでは 177.82-0ubuntu0.1 という形式となります。

ハードウェア・アクセラレータ対応の ATI™ ドライバーは、Linux では fglrx と名付けられます。例えば、Ubuntu システムではパッケージ名は fglrx-amdcccle など、バージョンナンバーは 2:8.543-0ubuntu4.1 などとなります。

Intel® 統合グラフィックス・アクセラレータ・ハードウェアは、パッケージ名に intel という文字列か、i810 などのチップセット情報が含まれることがあります。

rpm ベースの Linux ディストリビューション(SuSE、Red Hat Enterprise Linux など)

rpm ベースの Linux システムにインストールされているパッケージを調べるには、rpm -qa コマンドを実行します。このコマンドは、コンピューターにインストールされているすべてのパッケージを列挙するので、grep コマンドを用いて検索結果を制限することを推奨します。例えば、

rpm -qa | grep nvidia.

最新のドライバーソフトウェアの取得

ご使用のビデオカード用の最新のドライバーをダウンロードするには、ビデオカード販売元のウェブサイトをご覧ください。

ATI ビデオカード

http://support.amd.com/us/gpudownload/Pages/index.aspx に行き、ご使用のオペレーティングシステムとビデオカードの種類に対するドライバーソフトウェアを探してください。ビデオカード用のドライバーソフトウェアの最新のものをダウンロードし、インストールしてください。

注意: ATI Catalyst™ ビデオカードをご使用の場合は、Catalyst ソフトウェア・スイートをダウンロードしてください。

Intel ビデオカード

http://www.intel.com/support/graphics/ に行き、ご使用のチップセット・タイプに対するドライバーソフトウェアを探してください。ビデオカード用のドライバーソフトウェアの最新のものをダウンロードし、インストールしてください。

Windows でチップセット・タイプを調べる方法の詳細については、http://www.intel.com/support/chipsets/sb/cs-009245.htm をご覧ください。

Linux でドライバーソフトウェアを更新する方法の詳細については、http://www.intel.com/support/graphics/sb/cs-010512.htm をご覧ください。

NVIDIA ビデオカード

http://www.nvidia.com/Download/index.aspx に行き、ご使用のオペレーティングシステムとビデオカードの種類に対するドライバーソフトウェアを探してください。ビデオカード用のドライバーソフトウェアの最新のものをダウンロードし、インストールしてください。

Maple 16 Installation and Licensing Guideの先頭に戻る

ライセンスマネージャの設定

Windows でのライセンスマネージャの設定

Maple 16 の Windows Network バージョンを起動する前に、以下の手順に従いライセンスファイルを取得し、ライセンスマネージャを起動してください。

  1. 次のひとつを選択してください。

FlexNet Publisher と Activation Utilities をインストール

  1. DVD またはダウンロード先から NetworkToolsInstaller_Windows.exe をダブルクリックしてください。
  1. プログラムをすべて閉じてください。特に、Microsoft® Excel と Maple の古いリリースは必ず閉じてください。
  1. 画面の指示に従ってください。

ネットワークライセンスのアクティベーション

Maple 16 を操作するには、Maple 16 ライセンスファイルが必要です。それより前の Maple バージョンのライセンスファイルは Maple 16 では動作しません。ライセンスファイルを取得するには、Maple アクティベーションプログラムを使用するか、http://www.maplesoft.com/contact/webforms/offlineactivation/ に記載されている手順に従ってオフラインでアクティベーションを実行する必要があります。アクティベーション中にインターネット接続が必要になります。インターネットに接続できることを確認してください。ご使用のコンピュータがインターネットに接続していない場合は、Maplesoft 顧客サービスにお問い合わせください。

  1. スタート メニューから (すべての)プログラム>Maple Network Tools>Activate Maple を選択してください。注意: Windows Vista または Windows 7 を使用している場合は、Activate Maple を右クリックして 管理者として実行 を選択してください。
  1. ライセンスサーバーのパーチェスコード、ホスト名、ホスト ID を入力するためのプロンプトが表示されます。プロキシサーバーを介してアクティベーションを行う場合は、次へ をクリックする前に必ずこの情報を入力してください。
  1. アクティベーションを行うライセンス数など、その他の情報を入力するためのプロンプトも表示されます。入力したら 次へ をクリックしてください。
  1. ライセンスファイル Maple16.lic は、C:\Program Files\Maple Network Tools\activate フォルダに保存されます。次の手順でこのライセンスファイルが必要になります。

Maple 16 用のライセンスマネージャだけを起動

C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows ディレクトリには、Maple を実行するために必要なライセンスマネージャデーモン (lmgrd and Maplelmg) のほか、FlexNet Publisher のインストールおよび設定に使用するユーティリティが含まれています。

ライセンスマネージャ・デーモンの起動

Novell® サーバーを使用する場合は、Novell ネットワーク をご覧ください。

Windows ネットワークサーバー上でライセンスマネージャ・デーモンを設定・起動するには:

  1. スタートメニューから (すべての)プログラム>Maple Network Tools>LMTools11.7 を選択します。
  1. Service/License File タブ下で、Configuration using Services をクリックします。
  1. Config Services タブをクリックしてください。Server Name リストから現在使用されているサービスを選択してください。
  1. Config Services プロパティ・シートで、次のファイルまで移動するか、ファイル名を入力してください。
サービス名サービスの名前を入力(オプション)
lmgrd.exe ファイルへのパスC:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
ライセンスファイルへのパス 注意: ライセンスファイルへのパスには最後にバックスラッシュを付けないものとします。C:\Program Files\Maple Network Tools\activate\Maple16.lic
デバッグログファイルへのパス デバッグログファイルを含むディレクトリーへのパスを入力してください。このファイルは、自動生成されないため、自分で作成しなければなりません(下記の例では log.txt が自作ファイルです)。C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. デーモンをサービスとして設定する場合、Use Services チェックボックスを選択してください(デーモンは、サービスとして設定することを推奨します)。これは Windows XP、Windows Vista、Windows 7 で利用可能です。
  1. デーモンをブート時に起動するには、Start Server at Power Up チェックボックスを選択してください(デーモンはブート時に起動することを推奨します)。
  1. Save Service をクリックします。サービスを保存するためのプロンプトが表示されたら、Yes をクリックしてください。
  1. Start/Stop/Reread タブをクリックします。プロパティシートで Start Server をクリックすると、ライセンスマネージャ・デーモンが起動します。

これで、Maple 16 を使う準備ができました。

複数の Maplesoft 製品用にライセンスサーバーを起動

Maple とその関連製品を実行するには、すべてのライセンスファイルを同一のディレクトリーに入れる必要があります。ほかの FlexNet Publisher ライセンスファイルがひとつの場所に保存されている場合、Maple および関連製品のライセンスファイルもそこに置くことができます。

注意: Maple 16 とそれに関連付けられているツールボックスのライセンシングは、Maple 14 以降のライセンシングと互換性があります。ただし、Maple 14 より前のバージョンのライセンシングとは互換性がありません。バージョン 14 より前の Maple およびツールボックスでは、Maple 13 の Maple Network Tools を実行できます。

次の手順に従ってください:

ライセンスマネージャの停止
  1. 現在使用している FlexNet Publisher ユーティリティーのディレクトリーまで移動して、lmtools.exe をダブルクリックしてください。あるいは、スタート メニューから (すべての)プログラム>Maple Network Tools>LMTools11.7 を選択してください。
  1. Service/License File タブ下で、Configuration using Services をクリックします。
  1. Config Services タブをクリックしてください。Server Name リストから現在使用されているサービスを選択してください。
  1. Start/Stop/Reread タブをクリックしてから Stop Server をクリックしてください。
Maple ライセンスファイルすべてを共通のディレクトリに移動

Windows Explorer を使用して、すべてのライセンスファイルを C:\Program Files\Maple Network Tools\activate などの共通ディレクトリに移動します。

ライセンスマネージャ・デーモンの起動
  1. スタートメニューから (すべての)プログラム>Maple Network Tools >LMTools11.7 を選択します。
  1. Service/License File タブ下で、Configuration using Services をクリックします。
  1. Config Services タブをクリックしてください。Server Name リストから現在使用されているサービスを選択してください。
  1. Config Services プロパティーシートで、次のファイルまで移動するか、そのファイル名を入力します:
サービス名サービスの名前を入力(オプション)
lmgrd.exe ファイルへのパスC:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
ライセンスファイルへのパス 注意: ライセンスファイルへのパスには最後にバックスラッシュを付けないものとします。Windows Explorer を使用して、すべてのライセンスファイルを C:\Program Files\Maple Network Tools\activate などの共通ディレクトリに移動します。
デバッグログファイルへのパス デバッグログファイルを含むディレクトリーへのパスを入力してください。このファイルは、自動生成されないため、自分で作成しなければなりません(下記の例では log.txt が自作ファイルです)。C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. デーモンをサービスとして設定する場合、Use Services チェックボックスを選択してください(デーモンは、サービスとして設定することを推奨します)。これは Windows 2003、XP、Vista、7 で利用可能です。
  1. デーモンをブート時に起動するには、Start Server at Power Up チェックボックスを選択してください(デーモンはブート時に起動することを推奨します)。
  1. Save Service をクリックします。サービスを保存するためのプロンプトが表示されたら、Yes をクリックしてください。
  1. Start/Stop/Reread タブをクリックします。プロパティシートで Start Server をクリックすると、ライセンスマネージャ・デーモンが起動します。

これで、ネットワークライセンスの Maplesoft 製品が使用できます。

Novell ネットワーク

FlexNet Publisher は、Novell や IPX/SPX 上では実行できません。Novell のみの環境のネットワークでライセンスマネージャをインストールするには、次の手順に従ってください。

  1. すべてのクライアント・マシンに TCP/IP をインストールしてください。
  1. TCP/IP をインストールした Windows コンピュータをひとつ、ライセンスサーバーとして割り当て、「Maple 16 のみのためにライセンスサーバーを起動する」の手順に従いライセンスデーモンを実行してください。

Maple 16 Installation and Licensing Guideの先頭に戻る

Mac OS X 用にライセンスサーバーを設定

Maple 16 の Mac OS® X ネットワークバージョンを起動する前に、次の手順に従いライセンスファイルを取得し、ライセンスマネージャを起動します。

  1. 次のひとつを選択してください。

FlexNet Publisher と Activation Utilities のインストール

  1. FlexNet Publisher と Activation Utilities のインストールを開始するには、次のひとつを選んでください。
  1. Maple 16 DVD を DVD-ROM ドライブに入れてください。
  1. ファイルのダウンロード先から NetworkToolsInstaller_Mac.dmg をダブルクリックしてください。
  1. NetworkToolsInstaller_Mac アイコンをダブルクリックしてインストーラーを実行してください。
  1. 画面の指示に従ってください。

ネットワークライセンスのアクティベーション

Maple 16 を操作するには、Maple 16 ライセンスファイルが必要です。それより前の Maple バージョンのライセンスファイルは Maple 16 では動作しません。ライセンスファイルを取得するには、Maple アクティベーションプログラムを使用するか、http://www.maplesoft.com/contact/webforms/offlineactivation/ に記載されている手順に従ってオフラインでアクティベーションを実行する必要があります。アクティベーション中にインターネット接続が必要になります。インターネットに接続できることを確認してください。ご使用のコンピュータがインターネットに接続していない場合は、Maplesoft 顧客サービスにお問い合わせください。

  1. Finder から、アプリケーション -> ユーティリティターミナル ウィンドウを開いてください。
  1. アクティベーションユーティリティーのディレクトリーの場所を変えます。デフォルトは、 /Users/<username>/Applications/Maple_Network_Tools/activate
  1. コマンド ./activation を呼んでアクティベーションスクリプトを実行します。コンソールモードでアクティベーションを起動するには、-console オプションを使用してください。
  1. ライセンスサーバーのパーチェスコード、ホスト名、ホスト ID の入力プロンプトが表示されます。プロキシサーバーを介してアクティベーションを行っている場合は、必ずこれらの情報を入力してから 次へ をクリックしてください。
  1. アクティベーションを行うライセンス数を含めた追加情報の入力プロンプトが表示されます。情報をすべて入力したら 次へ をクリックしてください。
  1. プロンプトが出たら、ライセンスサーバーの名前または IP アドレスを入力してください。
  1. ライセンスファイル Maple16.lic が、ディレクトリー /Users/<username>/Applications/Maple_Network_Tools/activate に保存されます。次のステップでこのライセンスファイルが必要になります。

Maple 16 用のライセンスマネージャだけを起動

ライセンスマネージャ・デーモンの起動

Maple 16 を使えるようにするためには、ライセンスサーバーを起動しなければなりません。root によって実行されるプロセスはすべてセキュリティーリスクであるため、lmgrd を root として走らせることは推奨しません。

  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーのインストール先まで移動します。デフォルトでは、 /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/
  1. ライセンスマネージャ・デーモンを起動
  1. ライセンスマネージャ・デーモン(lmgrd)を起動するには、プロンプトに対し次のコマンドを入力してください。

./lmgrd -c license_file_path -l debug_log &

ここで、license_file_path はネットワークライセンスファイルのフルパスとファイル名(デフォルトは /Users/<username>/Applications/Maple_Network_Tools/activate/Maple16.lic)で、debug_log は、デバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

ライセンスサーバーの起動に関するヘルプ

システムブートアップファイルでライセンスサーバーを起動する際に問題が発生する場合は、http://www.flexerasoftware.com を参照してください。

これで、Maple 16 を使う準備ができました。

複数の Maplesoft 製品用にライセンスサーバーを起動

Maple とその関連製品を実行するには、すべてのライセンスファイルを同一のディレクトリーに入れる必要があります。ほかの FlexNet Publisher ライセンスファイルがひとつの場所に保存されている場合、Maple および関連製品のライセンスファイルもそこに置くことができます。

注意: Maple 16 とそれに関連付けられているツールボックスのライセンシングは、Maple 14 以降のライセンシングと互換性があります。ただし、Maple 14 より前のバージョンのライセンシングとは互換性がありません。バージョン 14 より前の Maple およびツールボックスでは、Maple 13 の Maple Network Tools を実行できます。

次の手順に従ってください:

ライセンスマネージャの停止

現在使われている FlexNet Publisher ユーティリティーのインストール先に移動してください。Maple 16 の場合、デフォルトのインストール先は /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/ となります。次のコマンドを入力してください。

./lmdown

Maple ライセンスファイルすべてを共通のディレクトリに移動

Maple のネットワークライセンスファイルをすべて /Users/<username>/Applications/Maple_Network_Tools/activate にコピーしてください。

ライセンスマネージャ・デーモンの起動
  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーのインストール先まで移動します。デフォルトでは、 /Users/<username>/Applications/Maple_Network_Tools/FLEXlm/11.7/
  1. ライセンスマネージャ・デーモンを起動するとき、すべてのライセンスファイルを含むディレクトリーへのパスを入力する必要があります。デフォルトは /Users/<username>/Applications/Maple_Network_Tools/activate

注意: ディレクトリーのパスで、ライセンスファイルそのものを指すものではありません。

  1. ライセンスマネージャを起動するには、次のコマンドを入力します。

./lmgrd -c license_file_path -l debug_log

ここで、license_file_path はライセンスファイルがあるディレクトリーのフルパスで、debug_log はデバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

これで、ネットワークライセンスの Maplesoft 製品が使用できます。

Maple 16 Installation and Licensing Guideの先頭に戻る

UNIX および Linux のライセンスマネージャの設定

Maple 16 の UNIX ネットワーク・バージョンを起動する前に、ライセンスファイルを取得し、次の手順に従ってライセンスマネージャを起動する必要があります。

  1. 次のひとつを選択してください。

FlexNet Publisher と Activation Utilities のインストール

  1. 次のひとつを選択してください。
  1. Linux 32 ビットでは、DVD またはファイルのダウンロード先から NetworkToolsInstaller_Linux.bin ファイルを実行してください。
  1. Linux 64 ビットでは、DVD またはファイルのダウンロード先から NetworkToolsInstaller_LinuxX86_64.bin ファイルを実行してください。
  1. Solaris では、DVD またはファイルのダウンロード先から NetworkToolsInstaller_Sun.bin ファイルを実行してください。
  1. 画面の指示に従ってください。

ネットワークライセンスのアクティベーション

Maple 16 を操作するには、Maple 16 ライセンスファイルが必要です。それより前の Maple バージョンのライセンスファイルは Maple 16 では動作しません。ライセンスファイルを取得するには、Maple アクティベーションプログラムを使用するか、http://www.maplesoft.com/contact/webforms/offlineactivation/ に記載されている手順に従ってオフラインでアクティベーションを実行する必要があります。アクティベーション中にインターネット接続が必要になります。インターネットに接続できることを確認してください。ご使用のコンピュータがインターネットに接続していない場合は、Maplesoft 顧客サービスにお問い合わせください。

  1. アクティベーションユーティリティー・ディレクトリーに移動してください。デフォルトでは、$HOME/Maple_Network_Tools/activate となります。
  1. activation コマンドを実行してください。コンソールモードでアクティベーションを起動するには -console オプションを指定します。
  1. ライセンスサーバーのパーチェスコード、ホスト名、ホスト ID を入力するためのプロンプトが表示されます。プロキシサーバーを介してアクティベーションを行う場合は、次へ をクリックする前に必ずこの情報を入力してください。
  1. アクティベーションしたいライセンス数などの情報を入力するプロンプトが表示されます。これが完了したら Next をクリックしてください。
  1. $HOME/Maple_Network_Tools/activate ディレクトリーにライセンスファイル Maple16.lic が保存されます。次のステップでこのライセンスファイルが必要となります。

Maple 16 用のライセンスマネージャだけを起動

ライセンスマネージャ・デーモンの起動

Maple 16 を使えるようにするためには、ライセンスサーバーを起動しなければなりません。root によって実行されるプロセスはすべてセキュリティーリスクであるため、lmgrd を root として走らせることは推奨しません。

  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーの場所に移動してください。これは、デフォルトとして $HOME/Maple_Network_Tools/FLEXlm/11.7/ となります。
  1. ライセンスマネージャ・デーモンを起動します。

C Shell の使用

プロンプトに対し次のコマンドを入力し、ライセンスマネージャ・デーモンを起動してください。

./lmgrd -c license_file_path -l debug_log &

ここで、license_file_path はネットワークライセンスファイルのフルパスとファイル名(デフォルトは $HOME/Maple_Network_Tools/activate/Maple16.lic)で、debug_log は、デバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

Korn Shell または Bourne Shell の使用

ライセンスマネージャ・デーモン(lmgrd)を起動するには、プロンプトに対し次のコマンドを入力してください。

nohup lmgrd -c license_file_path -l debug_log 2>&1 &

起動時のデーモンの実行

起動時にデーモンを実行するようにするには、適宜ブートスクリプト(例、/etc/rc.boot/etc/rc.local/etc/rc2.d/Sxxxx など)に変更を加えます。例えば、ブート起動スクリプトとして lmgrd を実行する場合、プロンプトに対し次の su コマンドを実行すれば、レギュラーユーザとして実行することができます。

su username -c \'umask 022; lmgrd_path -c license_file_path -l log_path\'

ここで、username は特権のないユーザ、lmgrd_path は lmgrd ファイルへの正しいパス、license_file_path はネットワークライセンスファイルへのフルパス(デフォルトでは $HOME/Maple_Network_Tools/activate/Maple16.lic)、log_path はデバッグログファイルのパスとします。ネットワーク・ライセンス・ファイルの名前は Maple16.lic とすることを推奨します。

ライセンスサーバー起動のヘルプ

UNIX のシステムブートアップ・ファイルからライセンスサーバーを起動する際に問題が発生する場合は、http://www.flexerasoftware.com/ を参照してください。

これで、Maple 16 を使用することができます。

複数の Maplesoft 製品用にライセンスサーバーを起動

Maple とその関連製品を実行するには、すべてのライセンスファイルを同一のディレクトリーに入れる必要があります。ほかの FlexNet Publisher ライセンスファイルがひとつの場所に保存されている場合、Maple および関連製品のライセンスファイルもそこに置くことができます。

注意: Maple 16 とそれに関連付けられているツールボックスのライセンシングは、Maple 14 以降のライセンシングと互換性があります。ただし、Maple 14 より前のバージョンのライセンシングとは互換性がありません。バージョン 14 より前の Maple およびツールボックスでは、Maple 13 の Maple Network Tools を実行できます。

次の手順に従ってください:

ライセンスマネージャの停止

現在使われている FlexNet Publisher ユーティリティーの場所に移動してください。Maple 16 では、デフォルトの場所は /usr/local/Maple_Network_Tools/FLEXlm/11.7/ となります。次のコマンドを入力してください。

./lmdown
Maple ライセンスファイルすべてを共通のディレクトリに移動

Maple ネットワークライセンスファイルをすべてひとつのフォルダー、例えば $HOME/Maple_Network_Tools/activate などにコピーしてください。

ライセンスマネージャ・デーモンの起動
  1. 使用しているオペレーティングシステムの FlexNet Publisher ユーティリティーの場所に移動してください。これは、デフォルトとして $HOME/Maple_Network_Tools/FLEXlm/11.7/ となります。
  1. ライセンスマネージャ・デーモンを起動するとき、すべてのライセンスファイルを含むディレクトリーのパスを入力する必要があります。デフォルトは $HOME/Maple_Network_Tools/activate となります。

注意: ディレクトリーのパスで、ライセンスファイルそのものを指すものではありません。

  1. ライセンスマネージャを起動するには、次のコマンドを入力します。

./lmgrd -c license_file_path -l debug_log

ここで、license_file_path はライセンスファイルがあるディレクトリーのフルパスで、debug_log はデバッグ情報の書き込み先ファイル名。-l オプション(アルファベットの l で、数字の 1 ではない)を指定すると、ファイルを作成します。

これで、ネットワークライセンスの Maplesoft 製品が使用できます。

Maple 16 Installation and Licensing Guideの先頭に戻る

指名ネットワークライセンシング

指名ネットワーク・ユーザは、各自のクライアント・マシン上で Maple を走らせます。クライアント・マシンはネットワークを介してライセンスサーバーに接続します。ネットワークの指名ユーザのライセンシング・オプションは、システム管理者が、Maple を走らせることができるユーザまたはクライアントマシンを厳格に管理することを可能にします。

Maple Network Tools をインストールすると、オプションファイル(.opt)が $Maple Network Tools/activate ディレクトリに自動的に生成されます。

注意: ベンダーデーモン maplelmg.opt は、デフォルトとしてライセンスサーバーマネージャが使うライセンスファイルと同じディレクトリ内でオプションファイルを探します。

指名ネットワークライセンシングの設定

指名ネットワーク・ユーザ・ライセンシングを設定するには、次の手順に従ってください。

オプションファイルの変更

オプションファイルを自分で変更する場合は、次の手順に従ってください。

  • オプションファイルのディレクトリに移動します。デフォルトでは $Maple Network Tools/activate
  • オプションファイル中の INCLUDE 文は、製品を走らせる権限を持つユーザーを指定します。各製品につき INCLUDE 文が必要となります。製品に対し複数のユーザーを指定する場合も、各ユーザーにつき INCLUDE 文が必要となります。別の方法として、GROUP 文を用いて権限を持つ指名ユーザーのグループを作ることもできます。
例 1: Maple を実行できるユーザーを指定

INCLUDE Maple USER User1

INCLUDE Maple USER User2

INCLUDE Maple USER User3

INCLUDE Maple USER User4

INCLUDE MapleExcel USER User4

例 2: Maple を実行できるユーザーを指定するための「グループ」を作成

GROUP Maple_users User1 User2 User3 User4

INCLUDE Maple GROUP Maple_users

INCLUDE MapleExcel USER User4

ライセンスマネージャを再起動します。

ライセンスマネージャを再起動しないとオプションファイルの変更は有効になりません。

Maple 16 Installation and Licensing Guideの先頭に戻る

Maple の起動方法

Maple 16 には、2 種類のワークシートインターフェイス (グラフィカルユーザーインターフェイス) とコマンドライン (テキストベース) インターフェイスが用意されています。デフォルトでは、ワークシートは改良された最新のスタンダードワークシートで開きます。32 ビット Windows および 32 ビット Linux プラットフォームで使用できるクラシックワークシートは、従来の Maple ワークシートの外観を持ち、メモリの消費量が少なくてすみます。Windows では、ワークシート・ファイルの関連付けセレクタアプリケーションを使用して Maple ワークシートのファイルの関連付けを変更できます。[スタート] メニューから [(すべての) プログラム] > [Maple 16] > [Tools] > [ワークシート・ファイルの関連付けセレクタ] を選択します。

スタンダードワークシート Maple

スタンダードワークシート Maple は、ドキュメントモードまたはワークシートモードのいずれかで起動することができます。

ドキュメントモードでは、問題をすぐに解くことができ、文法や Maple コマンドが必要ありません。テキストと数式を自由に組み合わせて、プレゼンテーション品質の数学ドキュメントを生成できます。

ワークシートモードは多くの Maple ユーザーになじみのあるモードです。入力プロンプトにコマンドを入力して結果を得ます。Maple 16 の新しい機能を使用して、ワークシートをプレゼンテーション品質のドキュメントに整形することもできます。

Windows

Windows でスタンダードワークシート Maple 16 を起動するには、以下の手順を実行します。

  • デスクトップから Maple 16 ショートカットアイコンをダブルクリックするか (ショートカットが作成されている場合)、スタートメニューから Maple 16 プログラムを選択します (Maple をデフォルトの場所にインストールしている場合、[スタート] メニューから [(すべての) プログラム] > [Maple 16] > [Maple 16] を選択します)。

Macintosh

Macintosh でスタンダードワークシート Maple 16 を起動するには、以下の手順を実行します。

  • Applications フォルダーの Maple 16 アイコンをダブルクリックします。

Solaris および Linux

UNIX または Linux でスタンダードワークシート Maple 16 を起動するには、以下の手順を実行します。

  • コマンド検索パスを変更して Maple 16 ディレクトリ (例: /usr/local/maple/bin) を含めます。次に、xmaple を実行するか、フルパス (例: /usr/local/maple/bin/xmaple) を実行します。

クラシックワークシート Maple

クラシックワークシート Maple は、Mac OS X プラットフォーム、64 ビット Windows、64 ビット Linux、Solaris では使用できません。

Windows

Windows でクラシックワークシート Maple 16 を起動するには、以下の手順を実行します。

  • クラシックワークシート Maple 16 プログラムを [スタート] メニューから選択しますMaple をデフォルトの場所にインストールしている場合、[スタート] メニューから [(すべての) プログラム] > [Maple 16] > [Classic Worksheet Maple 16] を選択します

Linux

32 ビット Linux ではクラシックワークシートを使用できます。UNIX バージョンでクラシックワークシートを起動するには、コマンドラインフラグが必要です。

クラシックワークシート Maple 16 を起動するには、以下の手順を実行します。

  • コマンド検索パスを変更して Maple 16 ディレクトリ (例: /usr/local/maple/bin) を含めます。次に、maple -cw を実行するか、フルパス (例: /usr/local/maple/bin/maple -cw) を実行します。

コマンドライン Maple

Maple のコマンドラインバージョンのユーザーインターフェイスはテキストベースです。Maple のコマンドラインバージョンでは、数学エンジンに全面的にアクセスすることができ、必要なシステムリソースが少なくてすみます。詳細については、Maple 16 フォルダにある readme.txt ファイルの「Command-line Maple」の節を参照してください。

Excel アドイン

Windows 版 Maple 16 には、Microsoft Excel 2007/2010 のアドインが用意されています。詳細は、Maple ヘルプシステムの Excel ヘルプページを参照してください。

注意: Microsoft Excel 2007 は、32 ビットアプリケーションとのみ互換性があります。そのため、Excel アドインを使用するには、32 ビット Windows インストーラを使用して Maple をインストールする必要があります。64 ビット Windows インストーラを使用して Maple がインストールされている場合、Excel アドインを使用できません。

Maple 計算機

Windows 版 Maple 16 には、便利なグラフ計算機インターフェイスが用意されています。

Maple 計算機を起動するには、以下の手順を実行します。

スタートメニューから Maple Calculator プログラムを選択します (デフォルトの場所に Maple をインストールしている場合、[スタート] メニューから [(すべての) プログラム] > [Maple 16] > [Maple 計算機] を選択します)。または、calculator.exe アイコン (bin.win サブフォルダ) をダブルクリックします。

マニュアル

スタンダードワークシートインターフェイスのヘルプメニューから、ユーザーマニュアルの電子版にアクセスできます。Maple 16 を起動して [ヘルプ] > [マニュアル、リソース、その他] > [マニュアル] を選択します。

Maple 16 Installation and Licensing Guideの先頭に戻る

Maple のカスタマイズ方法

ご使用の環境に合わせて Maple を設定することができます。

作業ディレクトリの変更方法

Windows 版の Maple では、Maple 16 のショートカットを作成して別のディレクトリを割り当てることで、作業ディレクトリを変更できます。

作業ディレクトリを変更するには、以下の手順を実行します。

  1. Maple の新しいショートカットを作成します。
  1. ショートカットアイコンを右クリックして、[プロパティ] を選択します。
  1. Maple の場所を [作業フォルダ] フィールドで変更します。[作業フォルダ] フィールドに表示されるディレクトリは、ショートカットキーを使用して Maple を起動したときの作業ディレクトリです。

起動時に、Maple は現在の作業ディレクトリ内でカスタム初期化ファイルを検索します。ファイルが見つかると検索が終了します。詳細は コマンドの自動実行方法 を参照してください。

コマンドの自動実行方法

起動時に自動で一連のコマンドを自動するように Maple を設定することができます。このアプローチは、Digits や Order などのグローバル変数の設定に特に役立ちます。このためには、Maple 初期化ファイルを作成します。詳細は、Maple ヘルプシステムの ?worksheet/reference/initialization を参照してください。

(Windows) スタンダードインターフェイスの起動オプションの変更方法

スタンダードワークシートインターフェイスは、ini ファイル bin.win/launch.ini を読み込みます (このファイルが存在する場合)。認識される指示は次のとおりです (コメントを含めるには、行の先頭にシャープ記号 (#) を指定します。シャープ記号の前に空白文字を入れないでください)。

# set maximum Java heap size
maxheap=700m
# additional args to pass to Java
java_args=-Dfoo -Dbar
# additional args to pass to Maple
maple_args=-q
# popup dialog showing the startup command (for debugging)
showcmd=true
# enable the Java access bridge (accessibility)
jaccess=true
# disable directX
java2d_nodraw=true
# set default language
language=Fr
# set default browser
browser="c:/Netscape"

注意: ランチャーで最適な値が使用されます。

MATLAB リンクの有効化

MATLAB© は汎用的な科学技術計算を行うための対話型プログラミング言語です。Windows、Macintosh、およびほとんどの UNIX/Linux プラットフォームでは、MATLAB® 2010b または 2011a がインストールされている場合、MATLAB と Maple のあいだのリンクを有効化できます。詳細は、Maple ヘルプシステムの ?Matlab/setup を参照してください。

Maple 16 Installation and Licensing Guideの先頭に戻る

Maple-NAG® Connector の使用方法

注意: NAG C Library Mark 8 のライセンスコピーでは、Maple-NAG Connector を使用する必要があります。NAG C Library のライセンスコピーの取得方法についての詳細は、Numerical Algorithms Group (NAG) にお問い合わせいただくか、here を参照してください。

インストール前の準備

  1. ご使用のプラットフォームの システム仕様 を確認してください。
  1. 管理者としてログオンするか、使用するアカウントに Maple ファイルに対する適切な読み取り/書き込み権限が割り当てられていることを確認してください。
  1. インターネットに接続できることを確認してください。ご使用のコンピュータがインターネットに接続していない場合は、販売元または Maplesoft 顧客サービスまでお問い合わせください。
  1. この製品には NAG C Library Mark 8 が必要です。NAG C Library はオペレーティングシステムに応じてさまざまな販売元から入手できます。詳細は、NAG,Platforms ヘルプページを参照してください。
  1. すべてのプログラムを閉じてください。

NAG C Library のインストール

Windows

  1. Windows 版の Maple-NAG Connector 製品と互換性のある NAG C Library Mark 8 を確認するには、Maple ヘルプシステムの NAG,Platforms を参照してください。
  1. Windows プラットフォームにおける NAG C Library Mark 8 の詳細なインストール手順を確認するには、here をクリックして、ページを下方向にスクロールし、ご使用の NAG ライブラリバージョンに対応するリンクをクリックしてください。
  1. Windows では、NAG C Library のインストールにより、システム環境変数 PATH が自動的に更新されます。これにより、Maple-NAG Connector がランタイムコンポーネントを見つけることができるようになります。
  1. NAG C Library をインストールしたら、Windows オペレーティングシステムを再起動して PATH 環境変数の更新を反映します。

Linux

  1. Linux 版の Maple-NAG Connector と互換性のある NAG C Library Mark 8 バージョンを確認するには、Maple ヘルプシステムの NAG,Platforms を参照してください。
  1. Linux プラットフォームにおける NAG C Library Mark 8 の詳細なインストール手順を確認するには、here をクリックして、ページを下方向にスクロールし、ご使用の NAG ライブラリバージョンに対応するリンクをクリックしてください。
  1. 環境変数 LD_LIBRARY_PATH の値で、NAG C Library のランタイム共有オブジェクトコンポーネントの場所が指定されている必要があります。

例えば、NAG C Library Mark 8 バージョン CLLUX08DGL が /user/local/nag/cllux08dgl/ にインストールされている場合、以下のバッシュシェルコマンドを使用して LD_LIBRARY_PATH を拡張できます。

LD_LIBRARY_PATH = /user/local/nag/cllux08dgl/lib:/user/local/nag/cllux08dgl/mkl_lib:$LD_LIBRARY_PATH::

export LD_LIBRARY_PATH

Macintosh (32 ビット)

  1. Macintosh 版の Maple-NAG Connector と互換性のある NAG C Library Mark 8 バージョンを確認するには、Maple ヘルプシステムの NAG,Platforms を参照してください。
  1. Macintosh プラットフォームにおける NAG C Library Mark 8 の詳細なインストール手順を確認するには、here をクリックして、ページを下方向にスクロールし、ご使用の NAG ライブラリバージョンに対応するリンクをクリックしてください。
  1. この製品を使用するには、32 ビットの Intel™ 互換アーキテクチャで OS® X を実行していなければなりません。
  1. 共有オブジェクトファイル libnagc_nag.dylib がシステムロケーション (ダイナミックランタイムリンカーのデフォルトの検索パス) にインストールされている必要があります。推奨されている場所は、/usr/lib です。
  1. システムロケーションに libnagc_nag.dylib をコピーする権限がない場合は、このファイルを Maple-NAG Connector の実行ファイルがインストールされている場所にコピーすることができます。このコピーは Maple-NAG Connector をインストールしてからでないと実行できません。

はじめる前に

インストール後に Maple-NAG Connector を使用するには、Maple-NAG Connector のスタートページを起動します。

Maple-NAG Connector スタートページの起動

  1. Maple 16 を開きます。
  1. ユーザーインターフェイスウィンドウで ?NAG,StartPage と入力します。

Maple-NAG Connector Start Page スタートページが表示されます。

Maple 16 Installation and Licensing Guideの先頭に戻る

システム仕様

32 ビット Windows システム仕様

バージョンCPU推奨 RAMハードディスク
Windows XP ProIntel Pentium III 650 MHz 以上、または完全互換2 GB2 GB
Windows XP HomeIntel Pentium III 650 MHz 以上、または完全互換2 GB2 GB
Windows Server 2008Intel Pentium III 650 MHz 以上、または完全互換2 GB2 GB
Vista Home BasicIntel Pentium III 1 GHz2 GB2 GB
Vista Home PremiumIntel Pentium III 1 GHz2 GB2 GB
Vista BusinessIntel Pentium III 1 GHz2 GB2 GB
Vista Ultimate EditionIntel Pentium III 1 GHz2 GB2 GB
Windows 7Intel Pentium III 1 GHz2 GB2 GB
Windows XP JapaneseIntel Pentium III 650 MHz 以上、または完全互換2 GB2 GB
Windows Vista または Windows 7 JapaneseIntel Pentium III 1 GHz2 GB2 GB
  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。

64 ビット Windows システム仕様

バージョンCPU推奨 RAMハードディスク
64-bit Windows Server 2008 R2AMD X86_64 1 GHz Intel Xeon, Intel 642 GB2 GB
64 ビット Windows (XP、Vista、または 7)AMD X86_64 1 GHz Intel Xeon, Intel 642 GB2 GB
64 ビット Windows (XP、Vista、または 7) JapaneseAMD X86_64 1 GHz Intel Xeon, Intel 642 GB2 GB
  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。
  • このプラットフォームではクラシック・ワークシートは提供されていません。

Macintosh システム仕様

ベンダーCPUオペレーティングシステムバージョン推奨 RAMハードディスク
AppleIntelOS X 10.6 2 GB2 GB
Apple64 ビット IntelOS X10.6, 10.72 GB2 GB
  • Java™ Runtime Environment 1.6.0_18 以上を実装
  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。
  • このプラットフォームではクラシック・ワークシートは提供されていません。

32 ビット Linux システム仕様

ベンダーオペレーティングシステムバージョンCPU推奨 RAMハードディスク
Red HatEnterprise 5Intel Pentium III 650 MHz または同等2 GB2GB
Red HatEnterprise 6Intel Pentium III 650 MHz または同等2 GB2GB
SUSE Enterprise Desktop10 SP3, 11 SP1Intel Pentium III 650 MHz または同等2 GB2 GB
Ubuntu10.04 LTS, 11.10Intel Pentium III 650 MHz または同等2 GB2 GB
  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • X11 R6.
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。

64 ビット Linux システム仕様

ハードウェア・ベンダーオペレーティングシステムバージョンCPU推奨 RAMハードディスク
AMD (X86_64)SUSE Enterprise 10 SP 3Intel 642 GB2 GB
AMD (X86_64)SUSE Enterprise 11 SP 1Intel 642 GB2 GB
AMD (X86_64)Red Hat Enterprise 5Intel 642 GB2 GB
AMD (X86_64)Red Hat Enterprise 6Intel 642 GB2 GB
AMD (X86_64)Ubuntu 10.04 LTSIntel 642 GB2 GB
AMD (X86_64)Ubuntu 11.10Intel 642 GB2 GB
  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • X11 R6.
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。
  • このプラットフォームではクラシック・ワークシートは提供されていません。

Solaris 動作環境

ベンダーシステムプロファイラー中、左枠の ハードウェア セクションを開き、グラフィックス/ディスプレイ をクリックしてください。ウィンドウの右側パネル中 チップセットのモデル の左にビデオカードが表示されます。(例、チップセットのモデル: ATI Radeon HD 2600Proオペレーティングシステムバージョン推奨 RAMハードディスク
OracleSPARCSolaris102 GB2 GB
  • DVD-ROM ドライブ(DVD インストール用)。
  • 解像度 1024 x 768 で 16 ビット色を推奨(最低条件)。
  • X11 R6.
  • 内部 TCP/IP 接続有効。
  • 推奨するメモリー仕様に達していない場合は、システムの性能に影響することがあります。
  • このプラットフォームではクラシック・ワークシートは提供されていません。

Web ブラウザ動作環境

MapleViewer を使用して HTML にエクスポートした 2-D Math を表示するには、以下のコンポーネントが必要です。

  • Java プラグインが有効化された Internet Explorer または Mozilla 2.0
  • Java Runtime Environment バージョン 1.6.0_18 以降

Maple 16 Installation and Licensing Guideの先頭に戻る

商標

注意: Maple は、ライセンスマネージャとして Flexera Software Corporation FlexNet Publisher を使用します。このドキュメントには、標準的な Maple インストールに必要な情報がすべて記載されています。詳細は、FlexNet Publisher のドキュメント http://www.flexerasoftware.com/ を参照してください。

Maple、Maplesoft、Waterloo Maple は、Waterloo Maple Inc. の商標です。

Intel は、Intel Corporation の登録商標です。

Microsoft、Windows、Windows Server、Windows Vista、Excel、Internet Explorer は Microsoft Corporation の登録商標です。

Macintosh と Mac OS は Apple Computer, Inc. の登録商標です。

NVIDIA は NVIDIA Corporation の登録商標です。

Java、JRE、Solaris は Oracle およびその関連企業の登録商標です。

FLEXlm は Flexera Software Corporation の登録商標です。

Linux は Linus Torvalds の登録表表です。

MATLAB は The MathWorks, Inc. の登録商標です。

その他あらゆるブランド名および製品名は、それぞれの会社の商標または登録商標です。

Maple 16 Installation and Licensing Guideの先頭に戻る