MapleSim Installation Guide

Maplesoft, a division of Waterloo Maple Inc.

Pre-installation Tasks

Single User Installation

Network License Installation

Getting Started

 


Verifying System Requirements

Maple Requirements
32-bit and 64-bit Windows System Requirements
32-bit Linux System Requirements
64-bit Linux System Requirements
Macintosh System Requirements

Maple Requirements

Before installing MapleSim, Maple 12 must be installed and activated on your computer. For Maple installation and activation instructions, see the Maple 12 Installation and Licensing Guide.

32-bit and 64-bit Windows System Requirements

Version
CPU

Recommended RAM

Hard Disk
Windows® 2000 Professional
Intel® Pentium® III 650 MHz or higher or fully compatible
512 MB
1 GB
Windows XP Pro
Intel Pentium III 650 MHz or higher or fully compatible
512 MB
1 GB
Windows XP Home
Intel Pentium III 650 MHz or higher or fully compatible
512 MB
1 GB
Windows Vista® Home Basic
Intel Pentium III
1 GHz
512 MB
1 GB
Windows Vista
Home Premium
Business
Ultimate Edition
Intel Pentium III
1 GHz
1 GB
1 GB

32-bit Linux System Requirements

Vendor
Operating System Version
CPU
Recommended RAM
Hard Disk
Red Hat®
Enterprise 4
Enterprise 5
Intel Pentium III 650 MHz or equivalent 512 MB 1 GB
SUSE®
9.3
10.1
10.2
Intel Pentium III 650 MHz or equivalent 512 MB 1 GB
Ubuntu®
7
Intel Pentium III 650 MHz or equivalent 512 MB 2 GB

64-bit Linux System Requirements

Hardware Vendor
Operating System Version
CPU
Recommended RAM
Hard Disk
AMD (X86_64)
SUSE Enterprise 9
SUSE Enterprise 10
Red Hat Enterprise 4
Red Hat Enterprise 5
Intel Pentium III 650 MHz or equivalent 512 MB 2 GB
Ubuntu 7
Intel Pentium III 650 MHz or equivalent 512 MB
2 GB

Macintosh System Requirements

Vendor

Processor

Operating System

Version

Recommended RAM

Hard Disk

Apple®

Intel

Mac OS® X

10.4.5 or later

512 MB

1 GB

Apple

G4, G5

Mac OS X

10.4.5 or later

512 MB

1 GB

 


MapleSim Single User Installation

During the installation process, you will need the purchase code that was sent to you in an email.

32-bit and 64-bit Windows

  1. Double-click the MapleSimWindowsInstaller.exe file located on your installation CD or in the directory where you downloaded the file.
  2. Follow the on-screen instructions. MapleSim is installed in c:\Program Files\Maple 12\toolbox\MapleSim.

32-bit and 64-bit Linux

  1. Run MapleSimLinuxInstaller.bin located on the installation CD or in the directory where you downloaded the file.
  2. Follow the on-screen instructions. MapleSim is installed in $HOME/Maple 12/toolbox/MapleSim, where $HOME is your home directory.

Macintosh

  1. Double-click the MapleSimMacInstaller.zip file located on your installation CD or in the directory where you downloaded the file and then double-click the MapleSimMacInstaller.app file icon.
  2. Follow the on-screen instructions. MapleSim is installed in /Library/Frameworks/Maple.framework/Versions/12/toolbox/MapleSim.

Activating Single User Versions

Starting MapleSim requires a MapleSim license file to operate. You must activate the single user version of MapleSim to obtain your license file. If you are running a single user installer, you can activate during the installation process. If you do not activate during the installation process, follow the steps below.
  1. Activation requires an Internet connection. If your computer does not have an Internet connection, please contact your distributor or Maplesoft customer service.
  2. Start MapleSim.
  3. When prompted to activate, click Activate.
  4. You will be prompted to enter your purchase code. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  5. You will be prompted to enter additional information. Click Next when this is complete.

*On Windows, you can also activate using the Start menu shortcut: Programs>MapleSim 1.0>Tools>Activate MapleSim 1.0.
*On Linux, you can also activate by running the activation script located in the $HOME/Maple12/toolbox/MapleSim/license directory.
*On Macintosh, you can also activate by running the activation script located in the toolbox/MapleSim/license folder of your Maple 12 installation. By default, /Library/Frameworks/Maple.framework/Versions/12/toolbox/MapleSim/license.

A MapleSim license file (MapleSim.dat) will be saved in the license folder of your MapleSim installation.

MapleSim Network License Installation

32-bit and 64-bit Windows

  1. Double-click the MapleSimWindowsInstaller.exe file located on your installation CD or in the directory where you downloaded the file.
  2. Follow the on-screen instructions
  3. In the Choose The Type of Licensing screen, select Network License
  4. When prompted, enter the name or IP address of the license server

MapleSim is now installed. Prior to using MapleSim, you need to configure the license manager.

32-bit and 64-bit Linux

  1. Log on to the account that will own the MapleSim files
  2. Run MapleSimLinuxInstaller.bin from wherever you downloaded the file.
  3. Follow the on-screen instructions
  4. In the Choose The Type of Licensing screen, select Network License
  5. When prompted, enter the name or IP address of the license server

MapleSim is now installed. Prior to using MapleSim, you need to configure the license manager.

Macintosh

  1. Double-click the MapleSimMacInstaller.zip file located on your installation CD or in the directory where you downloaded the file and then double-click the MapleSimMacInstaller.app file icon.
  2. Follow the on-screen instructions.
  3. In the Choose The Type of Licensing screen, select Network License
  4. When prompted, enter the name or IP address of the license server

MapleSim is now installed. Prior to using MapleSim, you need to configure the license manager.


Configuring the License Manager

32-bit and 64-bit Windows Network Licensing
32-bit and 64-bit Mac OS X Network Licensing
32-bit and 64-bit UNIX/Linux Network Licensing

32-bit and 64-bit Windows Network Licensing

Install FLEXlm and Activation Utilities

  1. Double-click NetworkToolsInstaller_Windows.exe from the CD or from where you downloaded the file.
  2. Follow the on-screen instructions.

Activate a Network License

  1. Go to C:\Program Files\Maple 12\toolbox\MapleSim\license and copy the activateMapleSim.bat and MapleActivation.jar files to C:\Program Files\Maple Network Tools\activate\
  2. Double-click on activateMapleSim.bat.
  3. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  4. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  5. A license file, MapleSim.lic, will be saved to the c:\Program Files\Maple Network Tools\activate folder. You will need this license file in the next step

Start the License Manager for MapleSim Only

The \FLEXlm\windows directory, installed in the c:\Program Files\Maple Network Tools directory, contains license manager daemons (lmgrd and maplelmg) required to run Maplesoft products, as well as utilities to assist you in installing and configuring FLEXlm for your system.

Start the License Manager Daemons

If you intend to use a Novell® server, see Novell Networks.

To set up and start the license manager daemons on a Windows Network Server:

    1. From the Start menu, select Programs >Maple Network Tools ->LMTools.
    2. Under the Service/License File tab, click Configuration using Services.
    3. Click the Config Services tab.
    4. In the Config Services property sheet, enter or browse to the following files:
Service Name Enter a name for the service (optional)
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\windows\lmgrd.exe
Path to the license file

C:\Program Files\Maple Network Tools\activate\MapleSim.lic
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\windows\log.txt
  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows 2000, 2003, XP, and Vista.
  2. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  3. Click Save Service. When prompted to save the service, click Yes.
  4. Click the Start/Stop/Reread tab. In that property sheet, click Start Server to start the license manager daemons.

You can now use MapleSim.

Return to the Top of the Document.

Start the License Manager for Multiple Maplesoft Products

To run MapleSim, Maple 12, previous releases of Maple and associated toolboxes, you must place all Maple license files in the same directory. If you have other FLEXlm license files stored in one central location, you can store the MapleSim license file there as well. Note: These steps do not apply to releases prior to Maple 6.

Complete the following tasks:

Task 1: Stop the License Manager

    1. Go to the directory of the FLEXlm utilities that are currently being used.
    2. Double-click lmtools.exe.
    3. Under the Service/License File tab, click Configuration using Services.
    4. Click the Config Services tab. From the Server Name list, select the service currently being used.
    5. Click the Start/Stop/Reread tab, then click Stop Server.

Task 2: Move all Maple License Files to a Common Directory

Using Windows Explorer, move all of the license files to a common directory, for example, C:\Program Files\Maple Network Tools\activate.

Task 3: Start the License Manager Daemons

    1. From the Start menu, select Programs >Maple Network Tools >LMTools.
    2. Under the Service/License File tab, click Configuration using Services.
    3. Click the Config Services tab.
    4. In the Config Services property sheet, enter or browse for the following:
Service Name Enter a name for the service (optional)
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\windows\lmgrd.exe
Path to the license file

Enter the path to the directory containing all of the license files. Point to the directory only, not an actual license file.

C:\Program Files\Maple Network Tools\activate
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\windows\log.txt
  1. To set up the daemons as a service (recommended), select the Use Services check box. This is available for Windows 2000, 2003, XP, and Vista.
  2. To start the daemons at boot time (recommended), select the Start Server at Power Up check box.
  3. Enter a name for your service and click Save Service. When prompted to save the service, click Yes.
  4. Click the Start/Stop/Reread tab, click Start Server to start the license manager daemons.

You can now use your network licensed Maplesoft products.

Novell Networks

FLEXlm does not run on Novell or IPX/SPX. Follow these instructions to install the license manager on any network that is exclusively a Novell environment.
  1. Install TCP/IP on all client machines.
  2. Select a Windows computer that has TCP/IP installed to act as a license server and run the license daemons using the Start the License Manager for MapleSim Only instructions.

 

32-bit and 64-bit Mac OS X Network Licensing

Install FLEXlm and the Activation Utilities

  1. To begin installing the FLEXlm and Activation Utilities, choose one of the following:
    1. Place the Maple 12 Macintosh CD in the CD-ROM drive.
    2. Double-click NetworkToolsInstaller_Mac.zip from where you downloaded the file.
  2. Run the installer by double-clicking the NetworkToolsInstaller icon.
  3. Follow the on-screen instructions

Activate a Network License

  1. From the Finder, open a terminal window from Applications -> Utilities.
  2. Change to the location of the activation utility directory. By default, /Users/username/Applications/Maple_Network_Tools/activate.
  3. Run the activation script by issuing the command ./activation. To launch activation in console mode, use the -console option.
  4. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  5. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is complete.
  6. A license file, MapleSim.lic, will be saved to the /Users/username/Applications/Maple_Network_Tools/activate directory. You will need this license file for the next step.

Start the License Manager for MapleSim Only

Start the License Manager Daemons

Before you can use MapleSim, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FLEXlm utilities for your operating system. By default, /Users/username/Applications/Maple_Network_Tools/FLEXlm.
  2. Start the license manager daemons.
  3. To start the license manager daemon (lmgrd), enter the following command at the prompt:

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, /Users/username/Applications/Maple_Network_Tools/activate/MapleSim.lic), and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Help for Starting the License Server

If you have any problems starting the license server in the system boot up files, refer to http://www.macrovision.com.

You can now use MapleSim.

Return to the Top of the Document.

Start the License Manager for Multiple Maplesoft Products

To run MapleSim, Maple 12, previous releases of Maple, and associated toolboxes, you must place all Maple license files in the same directory. If you have other FLEXlm license files stored in one central location, you can store the Maple license files there as well. Note: This does not apply to releases prior to Maple 6.

Complete the following tasks:

 

Task 1: Stop the License Manager

Go to the location of the FLEXlm utilities that are currently being used. For Maple 12, the default location is Users/username/Applications/Maple_Network_Tools/FLEXlm. Enter the command:

./lmdown -c license_file_path

Task 2: Move All License Files to a Common Directory

Copy all the network license files to /Users/username/Applications/Maple_Network_Tools/activate.

Task 3: Start the License Manager Daemons

    1. Navigate to the location of the FLEXlm utilities for your operating system. By default, /Users/username/Applications/Maple_Network_Tools/FLEXlm.
    2. When starting license manager daemons, you must enter the path to the directory containing all license files. By default, /Users/username/Applications/Maple_Network_Tools/activate.

Note: Point to the directory only, not an actual license file.

  1. To start the license manager, enter the following command:

./lmgrd -c license_file_path -l debug_log

where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to Top of the Document.

32-bit and 64-bit UNIX/Linux Network Licensing

Install FLEXlm and the Activation Utilities

  1. On Linux 32-bit, run the NetworkToolsInstaller_Linux.bin file from the CD or from where you downloaded the file.
    On Linux 64-bit, run the NetworkToolsInstaller_LinuxX86_64.bin file from the CD or from where you downloaded the file.
    On Solaris, run the NetworkToolsInstaller_Sun.bin file from the CD or from where you downloaded the file.
  2. Follow the on-screen instructions.

Activate a Network License

  1. Move the activateMapleSim and the MapleActivation.jar files from $HOME/maple12/toolbox/MapleSim/license to $HOME/Maple_Network_Tools/activate.
  2. Run the activateMapleSim command. To launch activation in console mode, use the -console option.
  3. You will be prompted to enter your purchase code, hostname, and hostid of your license server. If you are activating behind a proxy server, make sure to enter this information before clicking Next.
  4. You will be prompted to enter additional information including the number of licenses you are activating. Click Next when this is completed.
  5. A license file, MapleSim.lic, will be saved to the $HOME/Maple_Network_Tools/activate directory. You will need this license file for the next step

Start the License Manager for MapleSim Only

Start the License Manager Daemons

Before you can use MapleSim, you must start the license server. It is recommended that you do not run lmgrd as root because any process run by root is a potential security risk.

  1. Navigate to the location of the FLEXlm utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/
  2. Start the license manager daemons.

Using the C Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt,

./lmgrd -c license_file_path -l debug_log &

where license_file_path is the full path and filename of the network license file (by default, $HOME/Maple_Network_Tools/activate/MapleSim.lic) and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

Using the Korn or Bourne Shell

To start the license manager daemon (lmgrd), enter the following command at the prompt:

./lmgrd -c license_file_path -l debug_log 2>&1 &

Run Daemons on Startup

To have the daemons run on startup, edit the appropriate boot script (such as /etc/rc.boot, /etc/rc.local, or /etc/rc2.d/Sxxxx). For example, if you run lmgrd as a boot startup script, you can run it as a regular user by using the following su command at the prompt:

su username -c 'umask 022; lmgrd_path -c license_file_path -l log_path'

where username is a non-privileged user; lmgrd_path is the correct path to the lmgrd file, license_file_path is the network license file, and log_path is the debug log file. It is recommended that the network license file be called Maple12.lic.

Help for Starting the License Server

If you have any problems starting the license server in the UNIX system boot up files, refer to http://www.macrovision.com.

You can now use MapleSim.

Return to the Top of the Document.

Start the License Manager for Multiple Maplesoft Products

To run MapleSim, Maple 12, previous releases of Maple, and associated toolboxes, you must place all Maple license files in the same directory. If you have other FLEXlm license files stored in one central location, you can store the Maple license files there as well. Note: This does not apply to releases prior to Maple 6.

Complete the following tasks:

Task 1: Stop the License Manager

Go to the location of the FLEXlm utilities that are currently being used. For Maple 12, the default location is $HOME/Maple_Network_Tools/FLEXlm/ . Enter the command:

./lmdown -c license_file_path

Task 2: Move all Maple License Files to a Common Directory

Copy all of the Maple network license files to one folder, for example, $HOME/Maple_Network_Tools/activate

Task 3: Start the License Manager Daemons

      1. Navigate to the location of the FLEXlm utilities for your operating system. By default, $HOME/Maple_Network_Tools/FLEXlm/.
      2. When starting license manager daemons, you must enter the path to the directory containing all of your license files. By default, $HOME/Maple_Network_Tools/activate.

        Note: Point to the directory only, not an actual license file.

      3. To start the license manager, enter the following command:

        ./lmgrd -c license_file_path -l debug_log

        where license_file_path is the full path to the directory containing the license files and debug_log is the name of a file to which debugging information is written. The -l option (letter l, not the number 1 (one)) creates the file.

You can now use your network licensed Maplesoft products.

Return to Top of the Document.


Starting MapleSim

32-bit and 64-bit Windows

32-bit and 64-bit Linux

  1. At the command prompt, switch to the bin directory of your Maple 12 installation. By default, $HOME/Maple 12/bin.
  2. Run the command ./maplesim.

Macintosh


Trademarks

Maple, MapleSim, Maplesoft, and Waterloo Maple are trademarks of Waterloo Maple Inc.
Apple, Mac OS, and Macintosh are a trademarks of Apple Inc., registered in the U.S. and other countries.
Microsoft, Windows, and Windows Vista, are registered trademarks of Microsoft Corporation.
Intel and Pentium are registered trademarks of Intel Corporation.
Java Runtime Environment is a trademark of Sun Microsystems, Inc. in the United States and other countries.
Linux is a registered trademark of Linus Torvalds.
SUSE is a registered trademarks of Novell, Inc. in the United States and other countries.
Ubuntu is a registered trademark of Canonical Ltd.

All other brand names or product names are trademarks or registered trademarks of their respective companies.