MapleSim 4 インストールガイド

Maplesoft, a division of Waterloo Maple Inc.

インストール前のタスク

シングルユーザのインストール

ネットワークライセンスのインストール

はじめる前に

インストールおよび起動時の問題については、 トラブルシューティングを参照してください。


動作環境の確認

Maple の動作環境
グラフィックボードの動作環境
32-bit および 64-bit Windows 版の動作環境
32-bit Linux 版の動作環境
64-bit Linux 版の動作環境
Macintosh 版の動作環境

Maple の動作環境

MapleSim™ をインストールする前に、Maple™ 14 がインストールされ、かつアクティベーションが完了されていなければなりません。Maple のインストールやライセンス設定方法については、Maple 14 インストール・ライセンス設定ガイドを参照してください。

グラフィックボードの動作環境

MapleSim のグラフィックパフォーマンスを最適にするため、ビデオカードには最新のドライバソフトウェアを使用することを強く推奨します。お使いのビデオカードのドライバソフトウェアを確認およびアップグレードする手順の詳細については、Maple 14 インストール・ライセンス設定ガイドを参照してください。

32-bit および 64-bit Windows 版動作環境

OS バージョン
CPU
推奨メモリ
ハードディスク容量
64-bit Windows 2008 Server®
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
512 MB
1 GB
Windows XP Pro
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
512 MB
1 GB
Windows XP Home
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
512 MB
1 GB
Windows 2003 Server

Intel Pentium III 650 MHz またはそれ以降、互換 CPU

512 MB

1 GB

64-bit Windows (XP または Vista)
AMD X86_64
1 GHz
Intel Xeon
Intel 64
512 MB
1 GB
Windows Vista® Home Basic
Intel Pentium III
1 GHz
512 MB
1 GB
Vista
Home Premium
Business
Ultimate Edition
Intel Pentium III
1 GHz
1 GB
1 GB
Windows XP 日本語版
Intel Pentium III 650 MHz またはそれ以降、互換 CPU
512 MB 1 GB
Windows Vista 日本語版 Intel Pentium III
1 GHz
512 MB 1 GB
64-bit Windows (XP または Vista)
日本語版
AMD X86_64
1 GHz
Intel Xeon
Intel 64
512 MB 1 GB
Windows 7 Intel Pentium III
1 GHz
512 MB 1 GB
Windows 7 日本語版 Intel Pentium III
1 GHz
512 MB 1 GB

32-bit Linux 版動作環境

ディストリビューション
OS バージョン
CPU
推奨メモリ
ハードディスク容量
Red Hat®
Enterprise 5
Intel Pentium III 650 MHz または相応の CPU 512 MB 1 GB
SUSE®

10.3
11.1
11.2

Intel Pentium III 650 MHz または相応の CPU 512 MB 1 GB
Ubuntu®
8.04
10.04
Intel Pentium III 650 MHz または相応の CPU 512 MB 2 GB

64-bit Linux 版動作環境

ハードウェアベンダ
OS バージョン
CPU
推奨メモリ
ハードディスク容量
AMD (X86_64)
SUSE Enterprise 10
SUSE Enterprise 11
Red Hat Enterprise 5
Intel 64 512 MB 2 GB
Ubuntu 8.04
Ubuntu 10.04
Intel 64 512 MB
2 GB

Macintosh 版動作環境

ベンダ

プロセッサ

オペレーティングシステム

バージョン

推奨メモリ

ハードディスク容量

Apple®

Intel

OS X

10.5, 10.6

512 MB

1 GB

Apple

G4、G5

OS X

10.5

512 MB

1 GB

Apple 64-bit Intel OS X 10.5, 10.6 512 MB 1 GB
Apple 64-bit (G4、G5) OS X 10.5 512 MB 1 GB
  • Java Runtime Environment™ 1.6.0_18 またはそれ以降がインストール済みであること
  • 16-bit カラー、1024x768 以上の解像度をサポートするディスプレイ
  • TCP/IP 接続が必要

MapleSim シングルユーザのインストール

インストール処理中には、電子メールにて送付されたパーチェイスコードが必要になりますので、あらかじめご用意下さい。

32-bit および 64-bit Windows 版

注意:Maple および MapleSim を 64-bit Microsoft® Windows 環境でお使いの場合は、Microsoft® Visual C++ コンパイラをインストールして設定し、MapleSim のインターフェイスで compile オプションを使用する必要があります。Microsoft Visual C++ コンパイラを設定して Maple および MapleSim で使用する手順については、こちらを参照してください。

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4WindowsInstaller_ja.exe ファイルをダブルクリックします。
  2. スクリーンの指示に従います。MapleSim は c:\Program Files\Maple 14\toolbox\MapleSim4 にインストールされます。

32-bit および 64-bit Linux 版

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4LinuxInstaller.bin または MapleSim4LinuxX86_64Installer.bin を実行します。
  2. スクリーンの指示に従います。MapleSim は $HOME/Maple 14/toolbox/MapleSim4 にインストールされます。ここで、 $HOME はホームディレクトリを示します。

Macintosh 版

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4MacInstaller_ja.zip ファイルをダブルクリックなどにより展開し、さらに MapleSim4MacInstaller_ja.app ファイルのアイコンをダブルクリックします。
  2. スクリーンの指示に従います。MapleSim は /Library/Frameworks/Maple.framework/Versions/14/toolbox/MapleSim4 にインストールされます。

シングルユーザのアクティベーション

MapleSim を起動して利用するには、MapleSim 用のライセンスファイルが必要となります。ライセンスファイルを取得するには、シングルユーザ版 MapleSim をアクティベーション (認証) する必要があります。シングルユーザインストーラでは、インストール処理中にアクティベーションを実行することが可能です。インストール処理中にアクティ ベーションができなかった場合は、次の手順に従ってください。
  1. アクティベーションを行うコンピュータが、インターネットにアクセス可能であることを確認します。何らかの理由でインターネットにアクセスできない場合は、販売代理店または Maplesoft のお客様窓口までご連絡ください。
  2. MapleSim を起動します。
  3. アクティベーションのダイアログが表示されたら、[アクティベート] をクリックします。
  4. パーチェイスコードを入力するダイアログが表示されます。プロキシサーバを経由してアクティベーションを行う場合は、[次へ] をクリックする前に必要な情報を入力してください。
  5. プロキシサーバの情報については、お使いのシステムを確認するか、ネットワーク管理者にお問い合わせください。[次へ] をクリックして、アクティベーションを完了します。

※Windows の場合は、[スタート] メニューから [プログラム] > [MapleSim 4] > [Tools] > [Activate MapleSim 4] の順に選択して、アクティベーションを実行することもできます。
注意:Windows Vista、Windows 7 をご利用の場合は、[Maple アクティベーション] を右クリックして [管理者として実行] を選択してください。
※Linux の場合は、$HOME/Maple14/toolbox/MapleSim4/license ディレクトリ内の activation スクリプトを実行して、アクティベーションを行うこともできます。
※Macintosh の場合は、toolbox/MapleSim4/license フォルダ内にある activation スクリプトを実行して、アクティベーションを行うこともできます。デフォルトでは、このフォルダは /Library/Frameworks/Maple.framework/Versions/14/toolbox/MapleSim4/license となります。

MapleSim のライセンスファイル (MapleSim.dat) は、MapleSim をインストールしたフォルダ内にある license フォルダに保存されます。

MapleSim ネットワークライセンスのインストール

32-bit および 64-bit Windows 版

注意:Maple および MapleSim を 64-bit Microsoft Windows 環境でお使いの場合は、Microsoft Visual C++ コンパイラをインストールして設定し、MapleSim のインターフェイスで compile オプションを使用する必要があります。Microsoft Visual C++ コンパイラを設定して Maple および MapleSim で使用する手順については、 こちらを参照してください。

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4WindowsInstaller_ja.exe ファイルをダブルクリックします。
  2. スクリーンの指示に従いす。
  3. [ライセンスタイプの選択] 画面で [ネットワークライセンス] を選択します。
  4. ダイアログが表示されたら、ライセンスサーバのホスト名または IP アドレスを入力します。

以上で、MapleSim はインストールされました。MapleSim を使用する前に、必ず ライセンスマネージャの設定を行ってください。

32-bit Linux 版

  1. MapleSim ファイルを所有しているアカウントでログインします。
  2. ファイルをダウンロードした場所から MapleSim4LinuxInstaller.bin を実行します。
  3. スクリーンの指示に従います。
  4. [ライセンスタイプの選択] 画面で [ネットワークライセンス] を選択します。
  5. ダイアログが表示されたら、ライセンスサーバのホスト名または IP アドレスを入力します。

以上で、MapleSim はインストールされました。MapleSim を使用する前に、必ず ライセンスマネージャの設定を行ってください。

64-bit Linux 版

  1. MapleSim ファイルを所有しているアカウントでログインします。
  2. ファイルをダウンロードした場所から MapleSim4LinuxX86_64Installer.bin を実行します。
  3. スクリーンの指示に従います。
  4. [ライセンスタイプの選択] 画面で [ネットワークライセンス] を選択します。
  5. ダイアログが表示されたら、ライセンスサーバのホスト名または IP アドレスを入力します。

以上で、MapleSim はインストールされました。MapleSim を使用する前に、必ず ライセンスマネージャの設定を行ってください。

Macintosh 版

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4MacInstaller_ja.zip ファイルをダブルクリックなどにより展開し、さらに MapleSim4MacInstaller_ja.app ファイルのアイコンをダブルクリックします。
  2. スクリーンの指示に従います。
  3. [ライセンスタイプの選択] 画面で [ネットワークライセンス] を選択します。
  4. ダイアログが表示されたら、ライセンスサーバのホスト名または IP アドレスを入力します

以上で、MapleSim はインストールされました。MapleSim を使用する前に、必ず ライセンスマネージャの設定を行ってください。


ライセンスマネージャの設定

32-bit および 64-bit Windows ライセンスマネージャ設定
32-bit および 64-bit Mac OS X ライセンスマネージャ設定
32-bit および 64-bit UNIX/Linux ライセンスマネージャ設定

32-bit および 64-bit Windows ライセンスマネージャ設定

FLEXlm とアクティベーションユーティリティのインストール

  1. インストールディスク上、またはファイルをダウンロードした場所から NetworkToolsInstaller_Windows.exe をダブルクリックします。
  2. スクリーンの指示に従います。

ネットワークライセンスのアクティベーション

  1. c:\Program Files\Maple Network Tools\activate に移動します。
  2. activation アイコンをダブルクリックして、アクティベーションスクリプトを実行します。
  3. パーチェイスコードおよびライセンスサーバのホスト名とホスト ID を入力します。プロキシサーバを経由してアクティベーションを行う場合は、[次へ] をクリックする前に必要な情報を入力してください。
  4. アクティベーションを行うライセンス数等の必要な情報を入力し、[次へ] をクリックします。これで、アクティベーションが完了します。
  5. ライセンスファイル MapleSim4.licc:\Program Files\Maple Network Tools\activate フォルダに保存されます。次の手順では、このライセンスファイルが必要になります。

MapleSim のみのライセンスマネージャの起動

c:\Program Files\Maple Network Tools フォルダ下にある \FLEXlm\11.7\windows フォルダには、Maplesoft 製品の実行に必要なライセンスマネージャデーモン (lmgrd および maplelmg) と、お使いのシステムに FLEXlm をインストールして設定するときに役立つユーティリティが含まれています。

ライセンスマネージャデーモンの起動

Novell® サーバを利用する場合は、Novell Networksの項を参照してください。

Windows ネットワーク版ライセンスマネージャデーモンの設定および起動方法:

    1. [スタート] メニューから、[プログラム] > [Maple Network Tools] > [LMTools11.7] を選択します。
    2. [Service/License File] タブで、[Configuration using Services] をクリックします。
    3. [Config Services] タブをクリックします。
    4. [Config Services] プロパティシートで、次のファイルを入力または参照します:
Service Name サービス名を入力します (オプション)。
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
Path to the license file

C:\Program Files\Maple Network Tools\activate\MapleSim4.lic
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. Windows 2003、Windows XP、Windows Vista、Windows 7 については、[Use Services] チェックボックスにチェックを付けることで、デーモンをサービスとして設定することができます (推奨)。
  2. システムの起動時にデーモンを起動させる場合は (推奨)、[Start Server at Power Up] チェックボックスにチェックを付けます。
  3. [Save Service] をクリックします。サービスを保存するためのダイアログが表示されたら、[Yes] をクリックします。
  4. [Start/Stop/Reread] タブを選択し、このタブのプロパティシートで [Start Server] をクリックしてライセンスマネージャデーモンを起動します。

以上で、MapleSim をお使い頂けます。

このガイドの先頭に戻ります。

複数の Maplesoft 製品のライセンスマネージャの起動

MapleSim 4、 Maple 14 および関連するツールボックスを実行するには、すべてのライセンスファイルを同一のフォルダに用意する必要があります。その他の FLEXlm ライセンスファイルを 1 箇所にまとめて保存している場合は、MapleSim のライセンスファイルも同じ場所に保存することができます。

注意: MapleSim 4、Maple 14 および関連するツールボックスのライセンスは、以前の Maple のバージョンのライセンスとの互換性がありません。MapleSim 4、Maple 14 および関連するツールボックスの Maple ネットワークツールは異なるマシーンにインストールし実行しなければなりません

次の手順を実行します:

タスク 1:ライセンスマネージャの停止

    1. 現在使用している FLEXlm ユーティリティのあるフォルダに移動します。
    2. lmtools.exe をダブルクリックします。
    3. [Service/License File] タブで、[Configuration using Services] をクリックします。
    4. [Config Services] タブをクリックします。[Server Name] リストから、現在使用しているサービスを選択します。
    5. [Start/Stop/Reread] タブをクリックしてから [Stop Server] をクリックします。

タスク 2:すべての Maple ライセンスファイルの共通フォルダへの移動

Windows のエクスプローラを用いて、すべてのライセンスファイルを共通のフォルダ (例えば C:\Program Files\Maple Network Tools\activate) に移動します。

タスク 3:ライセンスマネージャデーモンの起動

    1. [スタート] メニューから、[プログラム] > [Maple Network Tools] > [LMTools11.7] を選択します。
    2. [Service/License File] タブで、[Configuration using Services] をクリックします。
    3. [Config Services] タブをクリックします。
    4. [Config Services] プロパティシートで、次を入力または参照します:
Service Name サービス名を入力します (オプション)。
Path to the lmgrd.exe file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\lmgrd.exe
Path to the license file

すべてのライセンスファイルが保存されているフォルダのパスを入力します。指定するのはフォルダのみとし、ライセンスファイルを直接指定しないでください。

C:\Program Files\Maple Network Tools\activate
Path to the debug log file C:\Program Files\Maple Network Tools\FLEXlm\11.7\windows\log.txt
  1. Windows 2003、Windows XP、Windows Vista、Windows 7 については、[Use Services] チェックボックスにチェックを付けることで、デーモンをサービスとして設定することができます (推奨)。
  2. システムの起動時にデーモンを起動させる場合は (推奨)、[Start Server at Power Up] チェックボックスにチェックを付けます。
  3. サービス名を入力し、[Save Service] をクリックします。サービスを保存するためのダイアログが表示されたら、[Yes] をクリックします。
  4. [Start/Stop/Reread] タブを選択し、[Start Server] をクリックしてライセンスマネージャデーモンを起動します。

以上で、ネットワークライセンス版の Maplesoft 製品をお使い頂けます。

Novell Networks を利用する場合

FLEXlm は Novell または IPX/SPX 上では動作しません。次の指示に従って、Novell 環境下のみにあるすべてのネットワークに、ライセンスマネージャをインストールしてください。
  1. すべてのクライアントコンピュータに TCP/IP をインストールします。
  2. TCP/IP をインストールしてある Windows コンピュータをライセンスサーバとして 1 台選択し、MapleSim のみのライセンスマネージャの起動の指示に従って、ライセンスマネージャデーモンを実行します。

 

32-bit および 64-bit Mac OS X ライセンスマネージャ設定

FLEXlm とアクティベーションユーティリティのインストール

  1. FLEXlm とアクティベーションユーティリティのインストールを開始するには、次のどちらかを選択します:
    1. Maple 14 Macintosh DVD を DVD-ROM ドライブに挿入します。
    2. ファイルをダウンロードした場所から NetworkToolsInstaller_Mac.zip をダブルクリックします。
  2. NetworkToolsInstaller アイコンをダブルクリックして、インストーラを実行します。
  3. Follow the on-screen instructions

ネットワークライセンスのアクティベーション

  1. [Finder] から [アプリケーション] > [ユーティリティ] の順に選択して [ターミナル] ウィンドウを開きます。
  2. /Users/username/Applications/Maple_Network_Tools/activate フォルダに移動します。
  3. ./activateMapleSim コマンドを発行して、アクティベーションスクリプトを実行します。アクティベーションをコンソールモードで行うには -console オプションを使用してください。
  4. パーチェイスコードおよびライセンスサーバのホスト名とホスト ID を入力します。プロキシサーバを経由してアクティベーションを行う場合は、[次へ] をクリックする前に必要な情報を入力してください。
  5. アクティベーションを行うライセンス数等の必要な情報を入力し、[次へ] をクリックします。これで、アクティベーションが完了します。
  6. ライセンスファイル MapleSim4.lic/Users/username/Applications/Maple_Network_Tools/activate フォルダに保存されます。次の手順では、このライセンスファイルが必要になります。

MapleSim のみのライセンスマネージャの起動

ライセンスマネージャデーモンの起動

MapleSim を利用するには、ライセンスサーバを起動しておかなければなりません。ここで、lmgrd は root アカウントで実行しない ようにしてください。すべてのプロセスが root 権限で起動することになり、セキュリティリスクが高まります。

  1. お使いのオペレーティングシステムの FLEXlm ユーティリティが格納されている場所に移動します。デフォルトでは、/Users/username/Applications/Maple_Network_Tools/FLEXlm/11.7 となります。
  2. ライセンスマネージャデーモンを起動します。
  3. ライセンスマネージャデーモン (lmgrd) を起動するには、プロンプトで次のコマンドを入力します。

./lmgrd -c license_file_path -l debug_log &

ここで、license_file_path は、ネットワークライセンスファイルのフルパスとファイル名です (デフォルトでは /Users/username/Applications/Maple_Network_Tools/activate/MapleSim4.lic)。また、debug_log は、デバッグ情報が書き込まれるファイルの名前です。 -l オプション (数字の 1 ではなくアルファベットの l) を指定すると、ファイルが作成されます。

ライセンスサーバの起動で問題が起きた場合

ライセンスサーバの起動時にシステムブートファイルで問題が発生した場合は、http://www.flexerasoftware.comを参照してください。

以上で、MapleSim をお使い頂けます。

このガイドの先頭に戻ります。

複数の Maplesoft 製品のライセンスマネージャの起動

MapleSim 4、 Maple 14 および関連するツールボックスを実行するには、すべてのライセンスファイルを同一のフォルダに用意する必要があります。その他の FLEXlm ライセンスファイルを 1 箇所にまとめて保存している場合は、MapleSim のライセンスファイルも同じ場所に保存することができます。

注意: MapleSim 4、Maple 14 および関連するツールボックスのライセンスは、以前の Maple のバージョンのライセンスとの互換性がありません。MapleSim 4、Maple 14 および関連するツールボックスの Maple ネットワークツールは異なるマシーンにインストールし実行しなければなりません

次の手順を実行します:

 

タスク 1:ライセンスマネージャの停止

現在使用している FLEXlm ユーティリティのある場所に移動します。Maple 14 の場合、デフォルトのフォルダは Users/username/Applications/Maple_Network_Tools/FLEXlm/11.7 です。次のコマンドを入力してください:

./lmdown -c license_file_path

タスク 2:すべてのライセンスファイルの共通フォルダへの移動

すべてのネットワークライセンスファイルを /Users/username/Applications/Maple_Network_Tools/activate にコピーします。

タスク 3:ライセンスマネージャデーモンの起動

    1. お使いのオペレーティングシステムの FLEXlm ユーティリティが格納されている場所に移動します。デフォルトでは、/Users/username/Applications/Maple_Network_Tools/FLEXlm/11.7 となります。
    2. ライセンスマネージャデーモンを起動するときは、すべてのライセンスファイルが含まれるディレクトリのパスを入力する必要があります。デフォルトでは、/Users/username/Applications/Maple_Network_Tools/activate となります。

注意:指定するのはフォルダのみとし、ライセンスファイルを直接指定しないでください。

  1. ライセンスマネージャを起動するには、次のコマンドを入力します:

./lmgrd -c license_file_path -l debug_log

ここで、license_file_path はライセンスファイルが保存されているディレクトリのフルパスです。また、debug_log は、デバッグ情報が書き込まれるファイルの名前です。 -l オプション (数字の 1 ではなくアルファベットの l) を指定すると、ファイルが作成されます。

以上で、ネットワークライセンス版の Maplesoft 製品をお使い頂けます。

このガイドの先頭に戻ります。

32-bit および 64-bit UNIX/Linux ライセンスマネージャ設定

FLEXlm とアクティベーションユーティリティのインストール

  1. 32-bit 版の Linux では、DVD-ROM またはファイルをダウンロードした場所から NetworkToolsInstaller_Linux.bin ファイルを実行します。
    64-bit 版の Linux では、DVD-ROM またはファイルをダウンロードした場所から NetworkToolsInstaller_LinuxX86_64.bin ファイルを実行します。
    Solaris では、DVD-ROM またはファイルをダウンロードした場所から NetworkToolsInstaller_Sun.bin ファイルを実行します。
  2. スクリーンの指示に従います。

ネットワークライセンスのアクティベーション

  1. activateMapleSim コマンドを実行します。アクティベーションをコンソールモードで行うには -console オプションを使用してください。
  2. パーチェイスコードおよびライセンスサーバのホスト名とホスト ID を入力します。プロキシサーバを経由してアクティベーションを行う場合は、[次へ] をクリックする前に必要な情報を入力してください。
  3. アクティベーションを行うライセンス数等の必要な情報を入力し、[次へ] をクリックします。これで、アクティベーションが完了します。
  4. ライセンスファイル MapleSim4.lic$HOME/Maple_Network_Tools/activate ディレクトリに保存されます。次の手順では、このライセンスファイルが必要になります。

MapleSim のみのライセンスマネージャの起動

ライセンスマネージャデーモンの起動

MapleSim を利用するには、ライセンスサーバを起動しておかなければなりません。ここで、lmgrd は root アカウントで実行しない ようにしてください。すべてのプロセスが root 権限で起動することになり、セキュリティリスクが高まります。

  1. お使いのオペレーティングシステムの FLEXlm ユーティリティが格納されている場所に移動します。デフォルトでは、$HOME/Maple_Network_Tools/FLEXlm/11.7/ です。
  2. ライセンスマネージャデーモンを起動します。

C Shell を使う場合

ライセンスマネージャデーモン (lmgrd) を起動するには、プロンプトで次のコマンドを入力します。

./lmgrd -c license_file_path -l debug_log &

ここで、license_file_path は、ネットワークライセンスファイルのフルパスとファイル名です (デフォルトでは $HOME/Maple_Network_Tools/activate/MapleSim4.lic)。また、debug_log は、デバッグ情報が書き込まれるファイルの名前です。-l オプション (数字の 1 ではなくアルファベットの l) を指定すると、ファイルが作成されます。

Korn Shell または Bourne Shell を使う場合

ライセンスマネージャデーモン (lmgrd) を起動するには、プロンプトで次のコマンドを入力します。

./lmgrd -c license_file_path -l debug_log 2>&1 &

ここで、license_file_path は、ネットワークライセンスファイルのフルパスとファイル名です (デフォルトでは $HOME/Maple_Network_Tools/activate/MapleSim4.lic)。また、debug_log は、デバッグ情報が書き込まれるファイルの名前です。-l オプション (数字の 1 ではなくアルファベットの l) を指定すると、ファイルが作成されます。

システム起動時にデーモンを起動する場合

システム起動時にデーモンを起動する場合は、/etc/rc.boot/etc/rc.local または /etc/rc2.d/Sxxxx などの起動用スクリプトを適宜編集します。例えば、プロンプトで次の su コマンドを使用して、システムのブート時に一般ユーザのアカウントで lmgrd を起動させるには、次のコマンドを実行します:

su username -c 'umask 022; lmgrd_path -c license_file_path -l log_path'

ここで、username は su 権限のないユーザアカウント、lmgrd_pathlmgrd ファイル、license_file_path はネットワークライセンスファイル、log_path はデバッグ用ログファイルの場所を示す正確なパスです。ネットワークライセンスのファイル名は MapleSim4.lic となっていることを推奨します。

ライセンスサーバの起動で問題が起きた場合

ライセンスサーバの起動時にシステムブートファイルで問題が発生した場合は、http://www.flexerasoftware.comを参照してください。

以上で、MapleSim をお使い頂けます。

このガイドの先頭に戻ります。

複数の Maplesoft 製品のライセンスマネージャの起動

MapleSim 4、 Maple 14 および関連するツールボックスを実行するには、すべてのライセンスファイルを同一のフォルダに用意する必要があります。その他の FLEXlm ライセンスファイルを 1 箇所にまとめて保存している場合は、MapleSim のライセンスファイルも同じ場所に保存することができます。

注意: MapleSim 4、Maple 14 および関連するツールボックスのライセンスは、以前の Maple のバージョンのライセンスとの互換性がありません。MapleSim 4、Maple 14 および関連するツールボックスの Maple ネットワークツールは異なるマシーンにインストールし実行しなければなりません

次の手順を実行します:

タスク 1:ライセンスマネージャの停止

現在使用している FLEXlm ユーティリティのある場所に移動します。MapleSim4, Maple 14 および関連ツールボックスの場合、デフォルトの場所は $HOME/Maple_Network_Tools/FLEXlm/11.7/ です。次のコマンドを入力してください:

./lmdown -c license_file_path

タスク 2:ライセンスマネージャデーモンの起動

      1. お使いのオペレーティングシステムの FLEXlm ユーティリティが格納されている場所に移動します。デフォルトでは、$HOME/Maple_Network_Tools/FLEXlm/11.7/ です。
      2. ライセンスマネージャデーモンを起動するときは、すべてのライセンスファイルが含まれるディレクトリのパスを入力する必要があります。デフォルトでは、$HOME/Maple_Network_Tools/activate です。

        注意:指定するのはフォルダのみとし、ライセンスファイルを直接指定しないでください。

      3. ライセンスマネージャを起動するには、次のコマンドを入力します:

        ./lmgrd -c license_file_path -l debug_log

        ここで、license_file_path はライセンスファイルが保存されているディレクトリのフルパスです。また、debug_log は、デバッグ情報が書き込まれるファイルの名前です。 -l オプション (数字の 1 ではなくアルファベットの l) を指定すると、ファイルが作成されます。

以上で、ネットワークライセンス版の Maplesoft 製品をお使い頂けます。

このガイドの先頭に戻ります。


Named ネットワークライセンスの設定

Named ネットワークライセンスユーザはクライアントマシーンで MapleSim を実行します。これらのクライアントはネットワークを経由してサーバに接続競れます。ネットワーク Named ユーザライセンスオプションはシステム管理者がどのユーザに、又はどのマシーンで MapleSim を実行させるか厳密に管理することができます。

ネットワーク Named インストールのパーチェイスコードで Maple Network Tools ネットワークツールをインストールする際には、オプションファイル (.opt) が $MAPLE NETWORK TOOLS/activateディレクトリに自動的に生成されます。

オプションファイルをマニュアルで変数するには以下の手順で行ないます。

例1: MapleSim4 を実行できるユーザを指定

INCLUDE Maple14   USER  User1
INCLUDE Maple14   USER  User2
INCLUDE Maple14   USER  User3
INCLUDE Maple14   USER  User4
INCLUDE MapleSim4  USER   User4

例2: GROUP 構文を利用し MapleSim4 と Maple14 を実行できるユーザを指定

GROUP Maple_users User1 User2 User3 User4
INCLUDE Maple14 GROUP Maple_users
INCLUDE MapleSim4 USER User4

 

 

 


MapleSim の起動

32-bit および 64-bit Windows 版

32-bit および 64-bit Linux 版

  1. コンソール上で、Maple 14 インストールディレクトリ内にある bin ディレクトリに移動します。デフォルトでは、$HOME/Maple 14/bin です。
  2. コマンド ./mapleSim4 を実行します。

Macintosh 版


64bit Windows 用 Microsoft Visual C++ コンパイラのインストールと設定

お使いのコンピュータに必要なソフトウェアをインストールして設定するには、次の手順に従ってください。

  1. 次のソフトウェアをダウンロードし、お使いのコンピュータにインストールします。
  1. Microsoft Windows SDK for Windows Server 2008 に付属している vcvars64.bat ファイルのパスを指定して、Maple 14 用に Microsoft Visual C++ コンパイラを設定します。vcvars64.bat ファイルのパスの指定には、次のいずれかの方法があります:

トラブルシューティング

問題:

マルチボディモデルをシミュレーションした後に、3-D 表示ウィンドウに 3-D アニメーションが表示されません。この問題は、Intel® 9XX シリーズのチップセットを搭載した Microsoft Windows マシンで発生することが報告されています。

Intel 製チップセットを確認する手順の詳細については、http://www.intel.com/support/chipsets/sb/cs-009245.htmを参照してください。

解決策:

お使いのコンピュータに、ビデオカードの最新のドライバソフトウェアがインストールされていることを確認してください。ご利用中のビデオカードのドライバソフトウェアを確認およびアップグレードする手順の詳細については、Maple 14 インストール・ライセンス設定ガイドを参照してください。


登録商標

Maple, MapleSim, Maplesoft, Waterloo Maple は、Waterloo Maple Inc の登録商標です。
Apple, Mac OS, Macintosh は、アメリカ合衆国及びその他の国における Apple Inc., の登録商標です。
Microsoft, Windows, Windows Server, Windows Vista は、 Microsoft Corporation の登録商標です。
Intel, Pentium は、 Intel Corporation の登録商標です。
Java Runtime Environment は、アメリカ合衆国及びその他の国における Sun Microsystems, Inc. の登録商標です。
Linux は、 Linus Torvalds の登録商標です。
SUSE は、アメリカ合衆国及びその他の国における Novell, Inc. の登録商標です。
Ubuntu は、 Canonical Ltd の登録商標です。

その他のブランド名または製品名は、各社の商標または登録商標です。

 

 

 

 

 

 

 

 

 

div>

64-bit Linux 版動作環境

ハードウェアベンダ
OS バージョン
CPU
推奨メモリ
ハードディスク容量
AMD (X86_64)
SUSE Enterprise 10
SUSE Enterprise 11
Red Hat Enterprise 5
Intel 64 512 MB 2 GB
Ubuntu 8.04
Ubuntu 10.04
Intel 64 512 MB
2 GB

Macintosh 版動作環境

ベンダ

プロセッサ

オペレーティングシステム

バージョン

推奨メモリ

ハードディスク容量

Apple®

Intel

OS X

10.5, 10.6

512 MB

1 GB

Apple

G4、G5

OS X

10.5

512 MB

1 GB

Apple 64-bit Intel OS X 10.5, 10.6 512 MB 1 GB
Apple 64-bit (G4、G5) OS X 10.5 512 MB 1 GB
  • Java Runtime Environment™ 1.6.0_18 またはそれ以降がインストール済みであること
  • 16-bit カラー、1024x768 以上の解像度をサポートするディスプレイ
  • TCP/IP 接続が必要

MapleSim シングルユーザのインストール

インストール処理中には、電子メールにて送付されたパーチェイスコードが必要になりますので、あらかじめご用意下さい。

32-bit および 64-bit Windows 版

注意:Maple および MapleSim を 64-bit Microsoft® Windows 環境でお使いの場合は、Microsoft® Visual C++ コンパイラをインストールして設定し、MapleSim のインターフェイスで compile オプションを使用する必要があります。Microsoft Visual C++ コンパイラを設定して Maple および MapleSim で使用する手順については、こちらを参照してください。

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4WindowsInstaller_ja.exe ファイルをダブルクリックします。
  2. スクリーンの指示に従います。MapleSim は c:\Program Files\Maple 14\toolbox\MapleSim4 にインストールされます。

32-bit および 64-bit Linux 版

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4LinuxInstaller.bin または MapleSim4LinuxX86_64Installer.bin を実行します。
  2. スクリーンの指示に従います。MapleSim は $HOME/Maple 14/toolbox/MapleSim4 にインストールされます。ここで、 $HOME はホームディレクトリを示します。

Macintosh 版

  1. インストールディスク上、またはファイルをダウンロードした場所で MapleSim4MacInstaller_ja.zip ファイルをダブルクリックなどにより展開し、さらに MapleSim4MacInstaller_ja.app ファイルのアイコンをダブルクリックします。
  2. スクリーンの指示に従います。MapleSim は /Library/Frameworks/Maple.framework/Versions/14/toolbox/MapleSim4 にインストールされます。

シングルユーザのアクティベーション

MapleSim を起動して利